SmartAlarm failing to change modes


(Cameron Murdaugh) #1

Two nights ago, as I was going to bed, I was setting the home to night. And the smart alarm app (the big deal custom one that was created a few months back) was failing to change to alarm away. After switching back and forth between home and night, it finally took after 3-5 swaps. The next day when i got home from work. It said disarmed, but then about 5 minutes after i got home the home alarm started going off. I had to swap it back to away and then home to get it to be considered disarmed. Then last night i struggled with the same problem from the night before. This one was slightly different because the Doors & Locks section of my app thought the back door was open (it had thought that since when the earlier issue popped up), but every other tile and all statuses on the website showed it as closed. I went downstairs opened and closed the door. When i put it into night it armed the house. Final example, we got home just now, and the house went into I’m back, but the app failed to disarm. What is happening? I have restarted the hub twice now. Was there an update to the hub or app?


Smart Alarm is here
(Cameron Murdaugh) #2

I may have fixed it by going into the app and Re-Hit Done. It seems to be more responsive. Does the Done button re-register stuff?


(Chuck Pearce) #3

Yes, opening the smartapp, and saving the changes re-initializes the app In doing so it reschedules all scheduled calls which is probably what fixed your issues.


(Jordan P.) #4

I’ve had some issues with door sensors getting stuck as open too, the last few days. ST just having some issues.


(Cameron Murdaugh) #5

How much do we know about the new hub and new OS ST will run under? I thought i heard they were moving to a linux based kernel instead of the homebrew. When I read this I was hoping that maybe these scheduling/event triggering bugs might start going away. They aren’t frequent, but they make the system inconsistent. If i am using this as a security system, I don’t want to worry about things like failed triggers and stuff like that.

Will the old hub move to the same OS? Is there a technical spec reason to upgrade to the new hub, even if i don’t care about some of the announced features?


(Megan) #6

I have been having the same issue for the last 2 days. Going into the app and re saving did not help.


(Chuck Pearce) #7

Which issue? The sensor(s) getting stuck, or the mode not changing? Which SmartAlarm are you running?


(Megan) #8

Sorry I was not clear. I am having the issue with the statusbits : Smart Alarm V2.2.5 not arming and disarming when the mode changes. Worked great until 4.7.2015


(Chuck Pearce) #9

Are you using Android or iOS?

Can you replace your current version of the SmartAlarm with this: https://gist.githubusercontent.com/chuckpearce/b0f4105dd7fa39d81bb5/raw/f255815a29cdf6eff49dfb9d8cd4781a2bf0c9fb/gistfile1.groovy

Then open your “Live Logging” console on the web-IDE.
Then open the SmartAlarm app on your device and save the settings. It should output a lot of debugging data if you can paste that back (remove any IDs or confidential information) or privatley message it to me and I will review it. I am guessing that either something is messed up with the mode handling in the “onLocation” function or the subscription to the location changes is not occurring.

Your issue is right in line with the Android update and some changes were made that broke some of the more advanced SmartApps.


(Megan) #10

I am iOS, will try what you suggested tonight when I get home


(Curtis Frazier) #11

I too am having a ton of issue with SmartAlarm. I updated to the latest version on Saturday and my modes are not changing.

Thankfully, my siren is not going off…but it really should be.