Smart Things incompatible on Samsung A02

I just upgraded my mom from a note 3 (yes, that correct), to a Samsung A02. And now that I am trying to install smart things but to no avail. I tried newer versions and older versions I also tried classic smart things.

Unfamiliar with the specs but three possible issues:

  • Android version must be 8.0 or higher
  • I’ve seen reports here of issues with small memory devices
  • I think I’ve seen reports here of minimum required screen resolution.

Search the forums for more info.

Thanks for your reply
Phone has Android 10
Device has 3 gigs of Ram
Screen size 6.5 with 720*1600 resolution.
Phone was launched in 2021.

I got smart things classic to install. But it won’t log in with her Samsung account but says that it sees that account attached to the phone.

The Classic app and that part of the platform was shutdown in the Fall of 2020 so you can’t use it.

Tagging @SamsungZell who can provide the requirements for the current ST app.

Thanks for you information

Hey there! @fivbag, I’m sorry to hear that you are having issues with installing the newest version of the ST App. If the ST App does not appear there may be a chance that the mobile device does not support the requirements needed or is not supported in your Region.

As far as the app requirements listed to run the ST App (Most recent verison: 1.7.67.29)
Released on 07-12-2021 are listed below:
[App requirements]
Some mobile devices may not be supported.

  • RAM size : 2GB over
  • Smart View

This particular section used to mention that Andriod 8.0 or higher was needed, as you mentioned Android 10 and the Memory of the device meets the listed requirements.

My initial thoughts would be to check if you see Smart View listed as an option on the device?
If unavailable on the Play store, Do you see the option to download the Smart Things App directly from the Galaxy Store?

Can you also provide me with the model code for your device located in the Settings Menu>About my device?

I hope this message finds you well!

^SamsungZell

Model number SM A022M/DS
I don’t have smart things installed on her phone. I don’t see smart things in Google play or Galaxy store.
I did try side load APK, that doesn’t install either. Gets error message saying incompatible.

Correction. Side load via direct install of smart things APK says
App not Installed.

Correction*****

As per region. I have ST installed on my S8 and she had it installed on her old Note 3. So I don’t think region is in play here. We still live the same place. My girlfriend has it installed on her S9 as well

Thank you so much for confirming that information.

The mobile device may not be supported or the ST APP APK you tried is for a higher Android version than what your device may support. The best way to obtain this information would be to reach out to a support team in your area. I do not have the ability to support models outside of the US. There are differences between the US and International firmware, which I do not have access to. As your product is a non-US model and support for these models is very limited, please seek a support team for your area. You can do so by using this link: https://www.samsung.com/us/common/visitlocationsite.html Visiting the country of origins website and selecting the contact us details will assist with getting in contact with your Smart Things Support Team to assist in verifying if that model is compatibile.

I hope this message finds you well!

^SamsungZell

I have since gone to the Samsung support website for my region.
I explained the situation and I was informed to 'i stall the app from the app store’s smh.
That’s one reason I don’t like dealing with support within my region.

Does anyone else have suggestions regarding fixing this issue?

My mom has no access to the security features which is what we primarily use smart things for.