My phone samsung A01 is not compatible with new smartthings app

I’ve just got a new phone, Samsung A01 (Android 10, 2gb Ram). I tried to download smartthings app at the playstore, it shows that this app is not compatible with your phone. So, I tried to get APK from my other phone (and downloaded several earlier version from apkmirrors), and I sideloaded apks. And the message shows that App not installed. So I tried to use apk editor and change the setting, and I finally installed the app. However, it crashes every time right after I give location permission. It looks like app is launching and crashes and out.
What can be a problem? Why this Samsung phone is not working with Samsung smartthings? I tried galaxy store (Samsung app store), it was not there. Please help!