Smart Locks SmartApp


(Jeff H) #1

It is a nice addition that you can manage codes now. I added another code as a test, then removed it.

But now I notice that when I unlock the door with the code, the status changes to unlocked, and then stays unlocked, even though the lock automatically relocks. If I click the refresh it will update back to locked. But doesn’t seem to be switching back on its own.

And on the wish list, I wish that I could set a trigger for when incorrect codes are entered X amount of times. I had that with Staples Connect.


Smart Locks not updating status
(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

What brand and model of Lock are you using? It might make a big difference.

The first step in keeping the app up to date is that it is up to the Lock (the device, not the DTH), to announce that its state has changed.


(Jeff H) #3

Schlage FE599NX lever. I applied the new smart app. Then I properly unpaired it, then re-paired it and re-applied the new smart app.
As far as I remember this was not the case before. It would change back to show locked status.


(Jeff H) #4

I thought it might be a battery issue, since it was at 73%. So I put new batteries in. No change. It reports unlock with the keypad on the front, and both lock and unlock from the buttons on the back instantly. But it is not reporting the auto-relock after using the keypad. I left it all night to see if it would update it did not. But if you manually tap either the “unlocked” graphic or the refresh icon under “right now” then it will update back to locked. So it seems it will always show unlocked in daily use if I do not manually refresh.

Also, subsequent unlocks by code from the keypad do not send the push notification and do not show up in history.


(www.rboyapps.com - Make your home your butler!) #5

That’s a feature of the lock. Some locks support configuring this parameters while others don’t. E.g. Schlage has a fixed number where as Yale can adjust it.


#6

I had this issue as well. I read a post from @JDRoberts and one the suggestions was to perform the the z-wave network repair. Haven’t had any problems since I did that. I have a Z-Wave Yale touchscreen lock.


(Jeff H) #7

It was reporting auto-relock status just fine before I added the new Smart Locks Smart App / and or the 2.10.1 update to the SmartThings Mobile. I cannot see how the lock is the cause of this problem, it is the one thing that didn’t change.


(Jeff H) #8

Tried that, didn’t help.


#9

I tried to find the post, but can’t find it now. In the post he said you may not see results until the next day. There were some other suggestions he had, but it worked fairly quickly for me.


#10

#11

Ok, so what happens if you remove the Smart Locks App?

Go back to where you started originally when you claimed it worked and then retest without the Smart Locks SmartApp being in your environment.

And were you using a different Device Handler for the lock prior to installing the Smart Locks App or have you always been using the stock Z-Wave Lock Device Handler?

One other thing to add to your to-do list - If you are running in Android, goto your App Settings and clear the SmartThings Cache and Force Stop the app.

Is your only issue that SmartThings isn’t automatically refreshing and displaying the correct device status under Things unless you hit Refresh?


(Geo Philips) #12

Hi, I just added this smart app but it says Code could not be created. I changed the device handler on my Yale Real Living ZWave lock to the stock Zwave lock with codes handler but it still does not work.

The community User Lock Manager app still works though


(Jeff H) #13

I believe it has to be Zwave lock, not Zwave lock with codes for the app to work.


(Geo Philips) #14

Thanks Jeff. You were absolutely right!


(Jeff H) #15

Yes I tried removing the Smart Locks App… didn’t help so I put it back. I have been using the same device handler, the Smartthings provided “Z-wave Lock”. I did re-pair it, could the Smartthings “Z-Wave lock” be a newer updated version and would I pull in those changes when I re-paired it? And of course there is the 2.10.1 Smarthings Mobile update… several variables to deal with…

The information is consistent across three android devices and in IDE… all will show the lock is unlocked even though it auto-relocked. I did try the force stop on one, no change.


#16

I just got a Schlage connect lock. Do you guys recommend using the new Smart Locks App or one of the custom apps like RBoy or the other free open-source one? My needs are super simple (add/remove/change codes and enable/disable codes for house cleaner).


(jkp) #17

The new Smart Locks app only allows you to add/delete codes. If you wish to change or enable/disable codes, you would need to use one of the other apps you mentioned.


#18

Thanks - that is what I needed to know.

I just got the open source app installed and it’s working ok with one exception. When I remotely unlock/lock from the SmartThings home screen, it takes a long time and it looks like the screen is not refreshing even if the action was done. When I go into the device screen I can see that the lock or unlock did work but on the home screen is just says “unlocking” or “locking” and never refreshes.


(jkp) #19

Probably best at his point to take your questions to the thread of the app you installed. But if you just installed the lock and it is z-wave, I would say run z-wave repair from the ST app first and see if that improves your issue.


#20

@charlesn100

And by using the new ST Smart Locks app, you only get Lock / Unlock features from the device itself within ST, whereas with the other custom apps, more of the locks internal features are exposed to the device in ST such as Keypad on/off, AutoLock On/Off, Audio On/Off, Touch lock On/Off etc.

And the new Smart Locks, well it’s still new and may have some kinks being worked out. :slight_smile: