Smart Lock Guest Access - "Couldn't download"?

Why is this not fixed yet? Its freaking January. I love Samsung, but get it together guys!

I think I just resolved this same issue on my devices, Wooooooo!!!
I was getting the “couldn’t download…” error message for months as well and kept waiting for a fix.
What finally solved this issue for me today was to go to my Pixel 3’s App Permissions option within the phone’s settings. I enabled all the permissions and then tried using the Smart Lock Guest Access again and this time it worked. I’m pretty sure it was specifically the storage access permission that helped, which might make sense, given the issue was download related. Once it was working, I disabled all of the permissions again and it’s still working.
Hope this works for y’all, too!

4 Likes

Wow, you got it! Now I’m so mad that I didn’t think about that… :joy:
I can confirm that it’s the storage permission for the app. I went to the app info for the SmartThings app and hit Permissions. Storage was listed under Denied, so I tapped it and hit Allow. I launched the app, hit Smart Lock Guest Access, and no download error!

Thanks! You figured out the simple fix that support couldn’t manage to get us for months!
Such an easy fix for them too. All they need to do is have the app prompt for the permission after an update…

I did not enable Storage permissions, but suddenly today, it just started working. Either way, relieved. I still had a tablet on Android 9 that I could use, but I manage an airBnb remotely, and feel better with some redundancy.

BTW, I did enable storage permissions a couple of weeks back, but when that didn’t change anything, I put it back to disabled. So, not sure that was actually a fix or if it was coincidental with Samsung getting a real fix in place. Either way, nice to have it working again.

I haven’t had a chance to confirm, but I have heard from colleagues that a plugin update went out today and this should be fixed. Please let me know if you’re still unable to download on Android 10.

1 Like

It’s finally working for me again on my Pixel 3XL, Android 10.

2 Likes

My storage permissions were already enabled so I disabled them and it’s working. I think they may have finally fixed the issue. :crossed_fingers:

1 Like

Agreed, whatever they updated finally worked, fully updated Pixel 3 here.

1 Like

This is an issue in the Pixel 4 as well. The new Smart Things Smart Locks app can see the existing locks, but I can not add new or delete old codes in the new app . The app says to locks installd.

Samsung has been silent on this issue.

In the meantime i have the Classic and new Smart things app on my phone just so I can alter lock codes.

This is troublesome. I really enjoy the Smart Things security systems, but I can’t continue to run two apps in order to manage my locks.

1 Like

It’s August 9th, 2020 and this is STILL an issue.

I’ve tried setting permissions, cleared cache and logged back into the new app, deleted the “Smart Lock Guest Access” and then tried to download by clicking on the Download button but I STILL get the “A network or server error occured”.

Running on Pixel 3

SmartThings recently changed the minimum requirement for their new ST app to Android 7 or higher. I don’t know if that’s affecting your situation. I’m assuming that you’re able to access other devices and app on your ST app (if not it may indicate a network connectivity issue).

Alternatively you can also look at the LUM app which runs on the new and the classic app and doesn’t have any region restrictions:

Are you using adguard or have a pihole on your home network?

No, I’m using Android 11 on a Pixel 3. I don’t have adguard or pihole or any network traffic blocking/inspecting software running on my network.

Ahhh Android 11 beta…

For anyone following this… I just updated to the official Android 11 app last night and it broke my smart lock guest access. Just got off the phone with Support and they were quick to admit the problem is on their end and they are working on it now to fix it.

1 Like

Ugh, I just upgraded to 11 as well and didn’t think to check. Just checked and same here. Glad they’re aware of it and hope that it doesn’t take them forever to resolve!

Yes, same here. upgrades to Android 11 yesterday and it broke the “smart lock guest access”.

Looks like I’ve been bitten by this too. Initially discovered this problem when I tried to view my Schlage lock and the app threw an error stating it needed to download but was unable to. Then I found this thread and tested Smart Lock Guest Access and couldn’t load that either.

Android 11 has been live for a week now, and was in beta since I think March. Apparently no one at SmartThings bothered to test things out?

I tried opening a support case about this but support refuses to help me because “beta OS isn’t supported” despite the fact that Android 11 is NOT beta anymore. :man_shrugging: