SmartThings Community

Smart Lighting Not Working


(Stephen LaRoche) #6

“device handler?” not sure what that is/means and I can’t seem to find it anywhere in the device settings. I just used whatever default device was indicated when I paired it with the hub.


(Ben W) #7

Double check the IDE logs.

What app are you using to automate? I assumed it was smart lighting, but if its something like CoRe then there may be a small misconfiguration.


(Stephen LaRoche) #8

When i go to investigate the logs, it says, “You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub.” How do I add my hub through the mobile app? I’m using the Smart Lighting app.


(Ben W) #9

It should route you automatically. Try this url: http://graph.api.smartthings.com

An dea just make smartlighitng to turn on when off (and not vice versa). Wonder if there is an order of execution issue when it is switching over.


(Stephen LaRoche) #10

Got the logs. When i manually click the switch, nothing in the logs. It’s not until I click it in the app that I get any feedback in the logs.

0606fa4a-af8e-4635-90e0-32d2471b6625 11:55:10 AM: debug Patched device state.
0606fa4a-af8e-4635-90e0-32d2471b6625 11:55:10 AM: debug Post the device state to server: fe8d1fd9-6afa-4314-8245-fa530646c72e
0606fa4a-af8e-4635-90e0-32d2471b6625 11:55:10 AM: debug Detected state change: fe8d1fd9-6afa-4314-8245-fa530646c72e
0606fa4a-af8e-4635-90e0-32d2471b6625 11:55:10 AM: debug Patched device state.
0606fa4a-af8e-4635-90e0-32d2471b6625 11:55:09 AM: debug Post the device state to server: 3198adaf-50df-400b-a4d1-e00fcd5b9215
0606fa4a-af8e-4635-90e0-32d2471b6625 11:55:09 AM: debug Detected state change: 3198adaf-50df-400b-a4d1-e00fcd5b9215
11:53:29 AM: info Waiting on events…
11:53:29 AM: info For past logs for individual things go to the My Devices section, find the device and click on the Events link on the device information page.
11:53:29 AM: info This console provides live logging of your SmartThings.


#11

OK, a couple of different things.

The IDE

First, SmartThings has multiple “shards” (can think of those like cloud-based database servers) and different accounts are associated with different ones.

SmartThings will let you sign into a shard not associated with your account, but when you do you won’t see any of your devices. :disappointed_relieved: (You would think smart things would route you automatically, but it doesn’t)

Because there are several different ones, it’s best not to just follow individual links from forum posts as the person posting might be on a different shard than you are.

The following FAQ lists the shards that exist at the present time:

FAQ: How to find out what "shard" (cloud slice IDE URL) your Account / Location is on?

What’s a Device Handler?

  1. as far as which device type handler you are using, if you just use the stock one when you added the device, you don’t have to worry about going into the IDE it all for now.

But to clear up the confusion, smart things terminology has changed several times. All of the following mean the same thing:

Device type
Device handler
Device type handler
DH
DTH

As for what they are, the custom code FAQ explains the concepts. You won’t need to follow any of the steps because you’re not using custom code, but it’s a good overview of what people are talking about so you might want to just read the first part anyway.


#12

As far as the problem you’re seeing, Try adding a Mode restriction to one of the two automations just to temporarily disable it and see if when there’s only one automation available, that works when you flip the physical switch. It shouldn’t matter which of the two you leave in place.

(You could also use a time restriction except I understand that yesterday’s app update broke the ability to save times for some situations, I don’t know the exact details.)


(Ben W) #13

If you manually change the switch does it update in Smartthings Device Handler (ie turn from off to on)?


(Stephen LaRoche) #14

I added the mode restriction (away) and was able to restrict one of the automations from running successfully.

When I manually trigger the switch in the room, the device status in the app is NOT updated (even after several minutes).

The device handler for the Switch is “Z-Wave Relay.” The device handler for the smart energy switch is “Z-Wave Metering Switch.”


#15

This is too obvious a question, but just to be sure…

When you tap the device icon in the mobile app, did you look to see if there was an actual physical event at the other device? That is, did you see the light or the nightlight actually come on?

You’re tracking two different behaviors here: The status changing in the app, and the actual physical device coming on. So let’s just verify that both of these are happening when you tap the device icon in the mobile app.


(Ben W) #16

Ok we have isolated your issue. The switch is not updating Smartthings of the status for whatever reason.

You mentioned Vera, was it removed from vera before adding to ST?

How far away is the switch from the hub? Maybe a range issue? (doubt it, but worth checking)

Is there an airgap on the switch to power cycle it? THe GE switches have that, and I know that fixes issues sometimes .

And maybe contact support. There could be something preventing communications from working. Its not uncommon for new hub to have some oddities when setting up.


(Stephen LaRoche) #17

When I tap the device in the app, the operation works perfectly. The light connected to the smart energy switch turns off and the night light connected to the light switch turns on.


#18

BTW, that’s the wrong device type handler for the Cooper. it should just pair as a generic zwave switch or dimmer. What model is the Cooper?


#19

Ben, as you know I can’t read the code or the log entries, but if this is a dimmer switch assigned to a binary switch device handler, it may be that it’s just not sending the command sets that the DTH expects. The whole set level zero thing.


(Stephen LaRoche) #20

It’s a Cooper RF9501AW


#21

OK, that’s a binary switch, but not a relay.

Try changing the device type handler to “Z-Wave Switch.”

you’ll need to go to the IDE

Choose my devices

Find the Cooper in the list and click on its name. That will open its details page

Go down to the bottom of that page and there should be a “edit” button. Click that.

That will open the edit page. You will be able to change the device type handler by choosing from a drop down. You just want to choose the generic Z wave switch.


(Ben W) #22

True, good catch.


(Stephen LaRoche) #23

BINGO!! I changed it to “Z-Wave Switch Generic” and it works flawlessly. Thanks for everyone’s help. This community is way more responsive and active than the vera community. Hoping for the stability and reliability I get from Vera on the ST.


#24

The community is great. Stability and reliability, not so much. :disappointed_relieved:

The company is definitely aware of it, and they have made improving stability their top priority, but they did that a few months ago and they’re not there yet.

The commitment is real, though – – they hired a senior engineer from Amazon in April to be their New head of engineering and work on scaling issues. So I do have hopes that it will improve. But for right now, people don’t choose smartthings for reliability. Just sayin’…


#25

Glad to hear it!

Don’t forget to remove the “away” mode restriction from the one automation if you haven’t already.