Smart Life, IFTTT, and smarthings Integrations keep repeating (27 Feb 2020)

I have 2 Smart Life plugs and in order to integrate with smartthings, I created 4 applets in IFTTT to turn plug on and off (1 from Smart life to ST and 1 from ST to Smart Life). It’s been working great so far and today something weird happened. The plugs keep turning on and off every hour automatically (based on IFTTT logs). What should I do to stop those behaviors?

Thank you

1 Like

I am having the same problem. Now going to delete them and do them over. Waiting to see if any suggestions are given.

1 Like

maybe this helps?


there are some FAQs in the link above that mention having virtual switches FAQ: Creating a virtual Device maybe can help if you haven’t created virtual switches

I had to create virtual devices in ST to do the applets

I have it set up like that. But today the devices started turning on and off on its own every 10 to 15 mins.

2 Likes

just today right? very weird. the annoying thing is one plug used for my garage and its kept open and close :frowning:

1 Like

sounds like a cloud - to - cloud issue…not sure if there’s anything else you can do besides to wait it out/pause them on IFFFT side for now.

Having the same problem which started a day ago. Seems to be on the Smartthings to Smartlife integration using IFTTT. I disabled the integration in IFTTT.

This is like the google (or Alexa) issue about a year ago when it it starts talking in the middle of the night :grinning:

1 Like

Same issue. 9 lights going on and off for the past 3 days . Was hoping for globe suite to come back and do the integration through them but I guess that’s not going to happen anytime soon so yeah. Maybe the new hub firmware will do the trick " Version: 0.29.8

Hub Target:

  • Samsung SmartThings Hub (Hub v2)
  • Samsung SmartThings Hub (Hub v3) (2018)

Release Date: 28 Feb 2020

Release Notes:

Features

  • Minor reliability and stability improvements to Zigbee and Z-Wave.
  • Address issue impacting stability of cloud communication channel for some workloads." :crossed_fingers:
1 Like

My hub v3 refuses to update :slightly_frowning_face: I’ve set the option to allow updates, but it’s at v28. May be the update is being rolled out in phases. Let’s wait and watch

My SmartLife plugs were set up to sync both ways with a simulated switch in ST using IFTTT but they developed a life of their own a couple of weeks ago. I only control them through ST, so I disabled the SmartLife->ST applets and they have been working fine since then. A poster on another link indicated that he had called the vendor of the SmartLife plug and they told him that Tuya (the company behind SmartLife) had stopped supporting IFTT so that is not a promising sign.

1 Like

How did you pair the SmartLife plug directly with ST? Did you just scan or… I’d love to do it that way.

Following.
Mine started doing same thing about the same time.

Same issue. I have been contacting the smart life support and they tried to blame IFTTT “timers” but I am not using IFTTT or ST timers to control these. I disconnected the IFTTT applets and the plugs stopped randomly turning on and off. So I guess I will use it through the smart life app only for the time being.

1 Like

Oh, thank goodness. I thought my house was haunted and my family was getting upset with me for not fixing the random lights. I have my smartlife plugs connected to SmartThings via IFTTT. I’m replacing the wifi plugs with zigbee plugs that smartthings directly supports. Much faster, not terribly expensive, and just a cleaner solution.

I have done a work around that seem to be working so far and is not being affected by the random turn on and off. I did two tap to run smart actions each in smart life to control a bulb and 2 ceiling fans I have. One for on and one for of per device. Then using ifttt the are linked to two virtual switches in ST. Works perfectly thus far for my bulbs and ceiling fans.

Is there a different type of applet in IFTTT for the “tap to run”? I added the “Tap to Run” actions in SmartLife but they are not showing up in IFTTT; I only see devices.

Select “Activate Scene”


1 Like

The way you show above is for ST -> Smartlife intergration right? I think the normal way with IFTTT work just fine with this, no need for sence.

I think the on/off problem happened with the Smartlife -> ST intergration instead.

1 Like

Thank you! Will try this. Hopefully SmartLife won’t break this type of integration.