Smartlife Outdoor Outlet won't integrate to SmartThings

I have an outdoor outlet which I control through the Smartlife App. Everything works fine but I am trying to get it to integrate to the Smartthings app. I can select Smartlife brand, and choose outlet as a type, but it does not select any device. In fact, in the Smartthings app when I choose Smartlife I get a message that says ‘Device compatible but not certified in the United States’. When I click on Smartlife it says ‘sucessfully connected to Smartlife’ but there are still no devices listed.

Any help is apreciated.

The integration is owned by the device manufacturer, so you need to get in touch with them. Smartthings publishes its API and after that it’s up to the device manufacturers to create and maintain the integration for their devices.

That said, quite a few people have reported similar issues with different devices using the smart life app and the usual suggested workaround is to create a scene in the Tuya app (as @Paul_Oliver notes below, the tuya app works better than the smart life app for this purpose) and usually that scene will come over to smartthings even though the device itself doesn’t.

This method will allow you to turn it on and off from smartthings. However, if you turn it on or off in any other way, SmartThings won’t know that it changed.

So not a full integration, but it may be better than nothing. :thinking:

1 Like

I have two that sit in a drawer. SmartLife is too hit or miss. If you want Wifi, get Meross. I have had great luck with them.

1 Like

If you open each device in the Smartlife/Tuya app and hit the edit icon it will list the “3rd party controls” that are available for that device.

I have 5 Smartlife devices. They all list Alexa and Google controls. Only 1 lists Smartthing.

In the Smartlife or Tuya apps create seperate “tap-to-run” on and off automations (scenes) for each device you want to use in Smartthings.

In Smartthings run the Tuya integration. Do NOT use the Smartlife integration. (The difference between the Smartlife and Tuya intrigations is that the Tuya integration doesn’t end with an error message. And when you look on linked services the imported scenes are listed under Tuya, unlike Smartlife which is blank.)

When you go back to the main page in Smartthings you will find on and off switchs for each device possibly in No Room Assigned.

They will say they are off line, ignore that for now.

I have been using WebCore with my Smartlife/Tuya devices to overcome the offline issue, and it works good. Reportedly Sharptools can also be used, but I have never tried it.

I create a virtual switch in Smartthings for each Tuya device.

In WebCore I create a piston for each device. The first part of the piston say toggle the “on” scene when the virtual switch is turned “on”. The second part of the piston say toggle the “off” scene when the virtual switch is turned “off”.

I have been using for months with no issues.

1 Like