Smart Life configuration problem - network?

Help !
I have a network problem when I try to install two iGenix panel heaters on my home network. Other smart devices have connected and function correctly, albeit with some initial problems.

In short, the configuration sequence between device and app running on mobile phone does not complete. It starts fine, but times out with an error.
In detail, the sequence is :-

  1. Installed app on mobile phone
  2. Switched iGenix heater to config mode (WiFi LED flashing quickly)
  3. Started app
  4. On app, switched to SSID of nearby Draytek hub
  5. On app, entered WiFi password
  6. On app, started configuration. (WiFi LED still flashing quickly)
  7. Spinner gets to 10% and panel heater’s WiFi LED goes out.
  8. Spinner gets to 20% and panel heater’s WiFi LED comes on, no flashing.
  9. At this point, the heater appears in the DHCP table and pings fine.
  10. Spinner goes all the way round to 100% and shows error.

I’ve repeated the sequence on both heaters.
I’ve used TWO apps - iGenix and SmartLife - both have the same behaviour.
I’ve used another phone - same problem.
There’s plenty bandwidth - I switched off three security cameras.
I switched the WiFi hub to 2.4 GHz and disabled 5 GHz.
WPA/WPA2-PSK enabled.
Tried AP mode - same problem. I note that the ‘private’ SSID of the heater appears - “SmartLife_D7F1”.
In the DHCP table, the devices appear as “EPS_DED7F1” and “EPS_DB69B7”. I see that the last six digits are the same as the last six digits in the MAC address. They have IP addresses assigned and they ping fine.

Now then, I tried to break down the problem by getting another mobile phone and switched it to a hotspot. This effectively cut out my WiFi hub and router. I went through the configuration sequence and it worked !!! This indicates that the phone works fine, the heater works fine.

Can anyone help ?

Many thanks,
Jim Burke

I’m afraid you won’t find much help for that device here. This forum is for SmartThings hub/app users, not Smart Life. Since Smart Life isn’t compatible with SmartThings, there isn’t much user overlap.

1 Like

Thanks anyway.

Jim