Smart Home Monitor - Serious Bug

shm

(brooklynite1) #1

Sometimes I feel I am the only one using Smartthings because of the major issues I run into that are largely ignored. Here is the issue I wanted to bring up today.

I have an automation routine calle AWAY that turns off all the lights, adjusts the thermostat and locks the doors , closes the garage door and puts the house on AWAY mode and turns on monitoring with SHM.

the problem is the order that this is activated.

After I run this, I get a barrage of notifications that lights are turning off WOO motion in garage because garage door just closed WOO scary stuff.

How DUMB is that the system turns off the lights ITSELF and warns me WOO lights turned off?

Why doesn’t SHM have a 10 second buffer before it starts monitoring and sending warnings?

Whats worse is that I have to go through about 9 clicks/taps/swipes/ to dismiss these notifications or they keep coming every hour (sometimes after 15 hours) like Zombie warnings “Hallway light turned off, 15 hours ago” WOO Scary stuff.

PLEASE FIX THIS STUFF SAMSUNG!


#2

With webCoRE you could control the execution order of turning off all the lights, then locking the doors, and running all the tasks you need to perform before actually arming the SHM to Armed (Away) and setting the Mode to Away as well. They would prevent whatever the order of the Routine is performing everything in.

If you don’t want to move over to the wonderful world of webCoRE and the power that has to offer, then you could use the community developed SmartApp:


#3

I don’t get those notifications. I only get notified when the motion sensor detects motion when SHM is in away mode. Have you checked your notification settings?

Also I have my Away Routine activate and turn on SHM to away mode five minutes after I leave. My motion sensor has a four minute reset.


#5

Why did you remove it @JDRoberts? Your posts are always a little more elloquent :grinning:


#6

You guys had it covered, and I’m just getting way too out of date on the software side since I haven’t been able to use the app for about six months. I just don’t know anymore what’s in a routine and what’s in smartlights and what the new smartapps do. So “least said, soonest mended” and all that. :sunglasses:


(Jimmy) #7

Sounds like a problem with your specific setup. I don’t get any alerts from SHM for my lights.


(Erik) #8

I also don’t have these issues. SHM routinely goes into away mode and everything works fine. Occasionally I will get a motion sensor trigger.

However - I did find out the hard way when I had my ring doorbell motion turn on the outside lights. Then I had the lights turn off after 10 minutes of being on. You know what happened? Every ten minutes (all night long) the ring motion sensor would trigger an event, when the lights when off…thereby turning the lights right back on. I can only imagine what my neighbors thought!

Ha!


#9

They couldn’t have been too upset as the cops didn’t show up.


(Arn B) #10

If Entry Delays are not required, the SHM Delay TrueExit app may be all that is needed to correct @brooklynite1 's issue.


(Arn B) #11

Suggest one minor alteration from the SHM Delay TrueExit directions.

Add the Garage door closure into the “Away Delay” routine so it runs while the system is Disarmed


(Mark) #12

Have you opened a ticket with support?

Because what you’re describing is not normal behavior for smart home monitor security alerts, and add me to the group of people that has never experienced what you’re describing.

Security alerts should only be triggered by contact and motion sensors.

Custom alerts in SHM can be set to notify you based on many additional triggers, but even there, lights aren’t one of them (last time I checked). And custom alerts have nothing to do with the security armed state (i.e. you can’t “arm” or “disarm” a custom alert, although you can restrict them to certain modes).

I agree with you there should be some ability to run the various actions in a routine in a certain order, though. But from what you described, that doesn’t seem like the only issue here.


#13

I have a similar setup, without the garage door closer, and I don’t have any of the other issues. Those issues need to be noted to support.

It is a known fact that there is no non “custom code” way to install a delay, Having said that, if I’m not in the garage when I arm the system, I’m not sure I would want it to ignore motion in the garage at that time. I would think you’d have the same issue when you exit the garage and arm before the door closes.

Obviously you could make it a two step process, and I do understand your not wanting to do that, but again, it’ll take custom code.

I know this is probably not an acceptable answer, but my thought on some issues like this is that these days it’s a $49 hub, with free “basic” home security software, that does a lot of other neat things as well. It certainly could be better, but it’s not a bad deal to me.


(brooklynite1) #14

Im not sure why no one 3lse has these issues but its frustrating.

Every morning I have a scene set to put the house on away mode, turn on SHM turn off all lights closed garage door lock all doors and turn off the AC.

So the SHM monitoring kicks in somewhere in between and starts giving alert notifications. Those notifications also dont go away they ate are sticky. If I dont go in the SHM and clear them, they pop up 40 hours later in middle of my dinner , phone call or a meeting.

You guys say contact support. How do i even describe my issue.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #15

Ummm… You just described it to us, right? Call Support and tell us the same thing. They can ask questions to clarify.

They also can see your exact configuration and make recommendations.

SmartThings support are experts at this stuff. They all use SmartThings. We hope.


(Jason "The Enabler" as deemed so by @Smart) #16

I recommend that you change three routine by removing SHM.

Create a virtual switch, call it SHM arm switch, and put that in the routine.

Then use WebCoRE to create a piston that is triggered by that switch turning on. Have it perform a 60 second wait, and then arm SHM.