Smart Alarm Help

smartapp

(Joel W) #1

I have Smart Alarm installed on my iPhone. I have three doors, two with 30 second delays setup. I am not sure if this is the way it should be working, but whenever I open a door with a 30 second delay even with my presence there I get a push alarm. Is there something I am doing wrong? I thought that the 30 seconds was to avoid an alarm. If I install an IRIS keypad would that help?

Also when I am in home mode I have a door that I go in and out many times when cooking dinner or out to read and it has no delay so I get an instant alarm. So how do I use that door when cooking so I am not getting all the push notifications. I tried to make a status button to replace night that would put the alarm off but the alarm doesn’t disarm. Any help would be appreciated. Thanks


(Geko) #2

No, this is by design. Usually, a hardware alarm panel starts to beep when someone enters protected zone to let you know that it’s armed. Since there’s no way to do that in SmartAlarm, it sends you a push message instead.

So how do I use that door when cooking so I am not getting all the push notifications.

You need to configure the door sensor as “interior” and use “Arm Stay” mode. In this mode, interior zones are not armed.


(Joel W) #3

Thank you for the quick responce. Can I suggest a modification to the app? I would like to see on the things page if possible or on the app page a quick disarm button so I can leave the security zone as exterior. This would allow me to have this patio door secure at all times as exterior. So when we go to sleep at night it isn’t disarmed like the motion detectors.

Also do you think the IRIS Keypad would work so I could disarm and arm from the panel. Since I have a 30 second delay I can get in and press the code and put the alarm in the state I need. Thanks again.


(Chrisb) #4

Is it just you using it Joel or do you have others who don’t have a phone?

You should be able to disarm by running a routine on your phone.


(Geko) #5

Of course, you can. Even better, you can modify it any way you want. It’s open source!


(Joel W) #6

I am far from a coder so I have no idea where to start. I tried by creating a routine, which would disable the alarm, but it doesn’t show in Smart Alarm. Any ideas?


(Joel W) #7

no others go in and out.


(Chrisb) #8

It’s not routines that arm/disarm SmartAlarm, but rather modes. What you want to do is setup “I’m Back” to change mode to home. Then you can just press “I’m Back” and it should disarm the Alarm.

The downside is that you need a phone/tablet to do that.


(Joel W) #9

OK on my Routines page I have Away, Home, Good Morning and night. But when I am “Home” my alarm is in stay mode which has the exterior doors alarmed and when I am “Away” my interior and exterior are armed. So how do I make a routine that will show in Smart Alarm. All that shows is Home, Away and night?

OK I made Night into Disarm so that seems to work. So now I have my Routines set. Thanks. Now for the IRIS I hope it works with Smart Alarm.


(Chrisb) #10

Ah… okay, so that’s a bit more complicated, but we can make it work.

Just a quick background… you’re using the app a bit outside of the way it was designed. That’s fine, but understand you’ll have to make a bit of “compensating controls” to get it to function the way you want.

The app is designed with three modes in mind:

Disarmed: There will be no alerts if any windows or doors are opened.
Armed-Stay: There will be alarms if exterior zones are opened, but interior are not 'armed.
Armed-Away: Every zone is armed and alerts will be sent for everything.

Because you’re never really using the “Disarmed” state, you’re use is a little different.

Here’s how I’d handle it:

Step 1: Create a new mode… In the mobile app, go to ‘locations’ then hit the gear to open settings for this location, then scroll to the bottom and tape ‘Add a new Mode.’ Call in “Entering” or whatever you want.

Step 2: In SmartAlarm, go to the Arming/Disarming Options and in the ‘Disarm in these Modes’ section select your newly created mode.

Step 3: Finally, create a routine called “Entering” or whatever you want to call it. Set this routine to change the mode to the new mode we created in step 1.

Now you can run the “Entering” routine to disarm SmartAlarm. After you are inside you home, tap the “I’m Back” routine to change mode to ‘home’ and your Alarm should then be reset.

Likewise, if you’re cooking and need to go in and out a lot, hit the Entering Routine to disarm you alarm until you are finished, then hit the I’m Back routine again to re-arm the alarm.


(Joel W) #11

Thanks for the info, just a few minutes too late. I created a Routine out of night since I never use it, I renamed it Disarm and then did as you said in Smart Alarm I used that in disable to disarm the alarm. Just would be nice to be able to disable a single door as needed. The only way of doing it now is going into the app setup. I am so accustomed to my alarm where I just chose a zone on the panel and hit bypass. I am hoping the IRIS keypad will allow me to arm and disarm from there. I am also using Life 360 as my presence sensor, much better than my phone always shows status of mine and my wife’s. By the way Life 360 is accurate to about 200 feet while the iPhone had a circle of 467 feet. So now My alarm arms faster and disarms when I am closer to home.


(Todd) #12

My suggestion may be out of left field, and especially since I’ve not used this app. (Disclaimer: I’m a ST noob) Don’t some security systems have a Bypass mode that can be applied to any zone? Is there a Bypass feature for this interior door that could be used during the time Joel is using it, then disabled when he is done?


(Joel W) #13

Yes you are correct there is a bypass mode for each of the switches, but no easy way to gain access. You have to go into configure the zone and select the switch to bypass then save. Yes it should be an option. But what I did was turned the night routine into a disarm routine, so yes it disables all exterior and interior for the time I am outside cooking. but another press on back and the alarm is armed in 390 seconds.


(Chrisb) #14

In a perfect world it would be an option, but remember that this is a free smart app that someone developed for their use and just gave to everyone else.

There’s a better option here. Because of how you are using the app you could do this. In the SmartAlarm SmartApp, configure things thusly:

  • This patio door sensor will be marked as internal.
  • All other sensors will be marked as external.

In the arming mode…
Night = Armed Stay
Home = Armed Away
Away = Armed Away

Now when you are in normal armed mode everything will alert when a door/window is opened. But, when you run the “Good Night” which puts your hub into ‘night’ mode, all exterior zones will be armed, but the patio door that is marked ‘interior’ will disarm. This way you still have security running for all the other areas, it’s JUST the patio door that’s off.

Again, hit “I’m Back” when you’re finished and everything is now armed.


(Joel W) #15

Yes I did that, but the patio door is the one that the people breaking in seem to use, so I want that alarmed when away and asleep. I was just making a suggestion that a bypass button be provided “Virtual Switch” that would disarm that door until pressed again. I tried to make a switch, but couldn’t get it to link with SA and the patio door. So I suggested it to the developer.


(Chrisb) #16

[quote=“joelw135, post:15, topic:38060, full:true”]
Yes I did that, but the patio door is the one that the people breaking in seem to use, so I want that alarmed when away and asleep.[/quote]

No I think you’re mis-understanding. With my method you would keep the your system in Armed-Away 99% of the time, so all “exterior” zones AND “interior” zones would be active. The only time the patio door would be ‘off’ would be when you manually change your system to night by pressing the night button. It would go back on when you press the “I’m Back” button.

How your using it right now:
All zones are armed, all the time until you press ‘Night’. Then ALL zones are disarmed until you press “I’m back.”

My method:
All zones are armed, all the time until you press ‘Night’. Then all zones are armed EXCEPT the patio door, which will be disarmed until you press “I’m back.”

Sorry, I probably sounded a bit heavy there… I didn’t want to yell at you or anything. We just need to be aware that the majority of SmartApps developed here are done by hobbyist for the most part and usually given freely.

Saying something SHOULD be a feature can be viewed by some somewhat of a demand. Not saying that geko took it that way or that you intended it that way. (Can you tell I’m dancing around here a bit trying to make sure I don’t offend anyone!! :slight_smile: :slight_smile: ) That’s all I’m trying to say.


(Joel W) #17

I didn’t mean to demand the bypass, it was just a suggestion and Geko did a great job on the app. He was the one to suggest the making the door internal. I am accustomed to my old alarm panel where you hit a button to bypass a zone. I realize this is not a real system with all the bells and whistles. And I would never demand anything from someone who did this great app on his own time. It is his design and he can do what he wants with it.


(Dale C) #18

I just loaded up VLC Thing and VLC to implement voice with my SmartAlarm. I think I got everything working OK because the Test piece works and makes it’s announcement on my Windows 10 tablet.

What I don’t know is what capabilities’ to expect from SmartAlarm Audio Notifications for a voice response. What I mean is if I do the custom responses for Alarm Phrase, Armed Away Phrase, etc they all trigger correctly when it goes into ARM mode for example which is great. I thought with SmartAlarm it would also notify me on status changes of the zones? I think I need to configure multiple instances of “Speaker Notify with Sound” for each zone maybe? I couldn’t see how to do that either.


(JIm) #19

In the Smartalarm alarm options, switches. Does this turn on the selected switches when there is an alarm? I selected a couple of my lights but they don’t come on when the alarm goes off.

2nd question. Is there a flag when the alarm goes off I can use in a core piston?

Thanks all.


(GarageDoor MartInc) #20

Hey, You can modify it any way you want.its open source code.