Smart alarm entry delay not working


(Jordon) #1

Can someone help me with my smart alarm delay? I’m using an iris keypad and everything is working but my entry and exit delay. Could someone help me out by chance?


(Brian Diehl) #2

Do you have the Entry/Exit Delays turned on for both Interior and Exterior zones?

By default, only Exterior zones have it set up.


(Jordon) #3

Yup have them all turned on. Had exit delay work a few days ago but now that’s not even working.


(Dana ) #4

Try removing and the re-configuring SmartAlarm, shouldn’t take more than a few minutes, and may resolve the wayward bytes that are causing problems.


(Robin) #5

I use CoRE for my entry delays:


(Joel W) #6

The problem with any type of cloud processing the operation is delayed depending on the SmartThings network. I have exit and entry with SA and have found sometimes on entry the time delay doesn’t get processed and the alarm sounds. I increased the delay, but it is the processing delay still sounds alarm.


(Jordon) #7

no luck with CoRE. Published The mart app and it’s nowhere to be found.


(Dana ) #8

After publishing the CoRE app, go into your SmartApps tab and then scroll to the bottom, select Add a Smart App, then select + My Apps, then choose CoRE from the list there.

After you starting using the app, it will be in your “normal” SmartApp list.


(Jordon) #9

Could you help me set up my CoRE app? Seems a little complicated and don’t know where to start.


(Robin) #10

Short of the example screenshot I posted on the link further up this thread it’s very hard for me to talk you through the specifics of setting up a piston… That’s really something you just need to play around with…

Have a stab at copying my example then click ‘CoRE Dashboard’ in the CoRE smartapp. It will load a web page where taking screenshots of your Pistons is a lot easier.

Post screenshots on here and I’ll try to give you some pointers.

You can also see how your pistons are working in real time via the dashboard which is handy for de-bugging your methods.


(Bryce88) #11

I had the same problem, I finally figured out that you have to ONLY use Smart Alarm and basically turn off the ‘Smart Home Monitoring’ alarm by disassociating all off your sensors with your monitoring modes so that it doesn’t do anything. Because what’s happening is it’s setting off the SHM alarm before it has a chance to do the delay. The only drawback is in order to set the alarm you can’t use the main buttons in the app and you have to use automation routines, or your iris keypad to arm and disarm the alarm. I just set up routines called armed-away, armed-stay, and home that basically just change the mode to away, night, or home respectively. Now it all works like a charm. Hopefully that makes sense.


(snewpy) #12

I am having a similar problem. Maybe I don’t understand how it is supposed to work, but when I arm the system and open one of the doors designated with a delay, I would expect after 30 seconds have elapsed that the alarm would go off at that point. It does not do that. Am I doing something wrong? Or is Smart Alarm just not meeting my expectations?