I cant figure out how to get the DELAY function to work on the Iris Keypad, any help would be appreciated


(thatninjachris) #1

thanks to all that have contributed to this.

im all set up with the iris keypad v2, shm, have the dth, ulm, and smartalarm, but i cant get the delays to function when arming and disarming…

can anyone be of assistance, what am i missing? i can find the option in smartalarm and have it set to 30 seconds, but i dont get 30 second notifications and it essentially doesnt delay??


#2

What version of SmartAlarm are you using?

At the top of the page in the link, there is a custom DTH and version of SmartAlarm. In that version it will be under Arming/Disarming Options. Also, the guys on that thread are really helpful with any IRIS related problems. I am new to this as well and they have helped me alot.


(thatninjachris) #3

i am using Version 2.4.3 (7/7/2015)


#4

Did you install a custom smart alarm app from one of the iris threads or is the stock one in the SmartThings app market?


(thatninjachris) #5

the one from the threads


#6

If it is the stock version, remove it in the SmartThings app. Then copy the smart alarm code in the link I posted into the new SmartApp section of the IDE and publish it for me. Then goto the Marketplace, SmartApps, and scroll down to My Apps. Install SmartAlarm in this section. Then set it up for your personal preferences. The delay will be under Arming/Disarming Options which is the 3rd choice under the setup menu.


(thatninjachris) #7

i am going to delete everything and give it another go… ill keep you posted in the next 45 mins… i appreciate the help btw


(thatninjachris) #8

just to be clear also… do you also use the basic interface the smartthings home monitoring? in conjunction with smartalarm?


#9

It can be frustrating. I am going to bed. If you cant get it, I will post in detail the method I used. I have had quite a bit of trouble myself.