Slow response to motion/triggers

I have a motion sensor that turns on a fan in the morning when I wake up.

Under the old app, or basically before I converted about 6mos ago, the motion triggered the fan near instantaneously. Now, under the new app and perhaps new backend, it can be delayed for about a minute. I know the app itself is just a window into the backend. But what has changed and can I fix it?

I have other ST triggers that react slowly too…

Any ideas?


If both devices are locally processed, have you tried using smart lighting to create your automation? If you can, the automation will run locally on your hub instead of in the cloud (which all automations in the new app do). You can verify that it’s running local in ide:


Awesome, thanks, I’ll try it. But it isn’t elegant. I wish I could control where the automations run, cloud or locally.

Moreover, if it’s in the cloud, does that mean if the internet is down, the automation won’t run?

Yeah, that’s correct. Smart lighting gives you the only option for local execution, but it isn’t always possible. Any change in mode, sthm, even using the app on your phone while on the same network requires the cloud.

1 Like

Thanks for your reply!

Unfortunately, parts of my trigger are cloud executed :frowning:

What do you all have going on with this automation? Unless I’m looking at this wrong, you have a simple motion sensor turning on a switch? That should easily be run local in Smart Lighting unless you’re using something like illumination as a condition.

Well, it is changing the security mode and the night to day, and triggerring some other switches that run off the cloud. However, in an unrelated issue, I’m toying with new smart switches that are zigbee and local (to strengthen my zigbee mesh that is causing my Samsung ST multisensors to drop off, at least that’s what I think). I can probably start swapping things around to make everything local. But it sounds like the security mode change may still be an issue.

This motion sensor also runs locally, but I discovered that my ceiling ones run in the cloud. Will mess around with that. I think yours and @saosinx88 's replies have nudged me to get everything local if possible.

Okay, confession time. I just discovered that the delay might have been… my fault. Whoops. I see there is an option for the motion sensor to have a motion duration, which I had set to 1 minute. Which explains why it didn’t trigger immediately like before. It was, in fact, doing what I told it to do.


1 Like