Shield Hub and Monoprice Bulbs


#1

I just got a SmartThings Link for the NVIDIA Shield and am trying to connect to some Monoprice RGBW bulbs.

I’m using the SmartThings app on Android to add and control devices.

I am able to initially add the lightbulb and see it on the app with the default name of RGBW Light in addition to the SmartThings Link called Home Hub. When tapping on Home Hub I see options, such as secure mode and allowing firmware updates. However, when I tap on the RGBW Light, I see an error Can’t connect to device. Check device and try again.

I’ve tried deleting and reinstalling the bulb to SmartThings, but the same error pops up.

Are the lightbulbs and Link compatible? Is there something I’m doing wrong? Any suggestions on how to be able to control the light?

Thanks


(Jimmy) #2

Which app are you using? Smarthings (Samsung Connect) or SmartThings Classic? Also, have you logged into https://account.smartthings.com and checked to see what device type got assigned to it!? It may require a custom handler that @RBoy developed.


#3

How do I know which app I am using?

I tried connecting it to Google Home (Assistant?), and am able to control colors by telling Google Assistant which color. Just cannot use the SmartThings app I’m using.


(Jimmy) #4

What the icon look like? One circle or 6 circles?


#5

The icon looks like 6 circles.


(Jimmy) #6

That’s the new app. Install SmartThings Classic and login with your same credentials.


#7

Yay!

Thank you!!! It works great now, and I’ve started to explore making SmartApps now. -rubs hands together greedily-