Shelly wifi device integration

On shelly app, go to device, app setting, here you can configure as light or socket, yesterday only show sockets, are testing on beta. Samsung now have to do it, I think on a few days show all devices.

If you change the type in socket all is ok

SmartThing support Shelly from today officialy.

Schema Connector (Beta version) released (24.01.2020)

Current limitations:

Since SmartThing and we are still working on the Schema Connector some missings may happen.




List of supported devices

● Shelly plugs - ‘SHPLG-1’ and ‘SHPLG-S’,

● Shelly Color Bulb - ‘SHBLB-1’,

● Shelly relay/roller - ‘SHSW-21’ and ‘SHSW-25’,

● Shelly Switch ‘SHSW-1’, ‘SHSW-PM’ and ‘SHSW-44’,

● Shelly Dimmer ‘SHDM-1’,

● Shelly H&T ‘SHHT-1’,

● Shelly Smoke ‘SHSM-01’

Supported controls

For relays and plugs:

● Turn On/off control

● Power meter graphic for devices support it

For Shelly 2 and Shelly 2.5 in roller mode

● Open/close control available

● Persent control (0-100), only for calibrated devices

For lights:

● Turn On/Off control for all lights

● Dimmer control (0-100 %) for all lights

● Color control only for devices support that one

● Color Temperature control only for devices support that


● Shelly H&T shows temoperature, humidity and battery value

● Shelly Smoke shows smoke detection, temperature and battery value


Guys my relay are set As lights and they do show. Now the two shelly 1 missing are visibile. The only one left is a single channel of a 2.5 shelly. The other shelly 2.5 I own shows fine. The difference between the two are that the one that is working properly is configured in shelly app to have both channels in the same room. The one that has one channel missing has one channel in a room and the other in another room. Maybe this is the reason why it doesn’t show

Ok, perhaps they are testing yet.


Does the Shelly RGBW2 work with the new integration? Wanted to buy one to control a RGBW led strip.


I am trying to connect a Shelly 2.5 but the only option that apear is a button

Is there any way to have acess to all the others devices?

I manage to connect the Shelly 2.5 as a roller shuter but unfortunatly it does not shows the status

Any idea what am i doing wrong…

Hi ,
I had the shelly as a roller shutter DH and it used to work very good except when I used the button to open/close the roller shutter it didn’t show up in the app so I used webcore to sync it and this worked good.
After Shelly announce the integration I tried it and it’s ok but not as good as using the DH and more important is that webcore and Actiontiles don’t see it as a switch or dimmer or something that I can work with .

now when I tried to use again the DH it doesn’t work .
Some more info :
I replaced the router so my ip’s had changed (I did change it on the device settings)
since it took me couple of weeks to replace my router I didn’t use the roller shutter from ST or AT and it showed as offline because the ip was wrong (so I thought )
The same issue happen to me with the yeelight DH (change the ip but it’s not reacting )

Any Ideas ?

Just got mine, seems like it doesn’t work.

Duccio, great work, for me operates for Roller Shutter, there was an issue with the state, please check my code…

Please correct me if I’m wrong, but does this Official Support for Shelly mean that it’s cloud-only? So if my Internet connection goes down I won’t be able to use the Shelly Dimmer 2?

I need something that can be executed locally because sometimes during summer my 4G connection gets so bad (nearby camping using the same tower) everything that goes over the internet takes forever to execute.

I also have the Hue bridge if that helps anything.


1 Like

yes, the official support for shelly work with cloud only… unfortunately

That’s true, but the physical buttons on the walls will of course still work (no idea why I didn’t think of that previously?) so they will work fine for me.

Yes sure, the button wall work fine, but i have a lot of false displays of lamps on or off in the smartThings app and I think the problem is due to the passage to the cloud. I was also hoping to be able to use them locally

So bulbs doesn’t show the correct status in SmartThings? Does it show the correct status in the Shelly app?

Same time doesn’t show the correct status, but not every time. In the app shelly is correct. this is on example. Only if I use the button in the wall.

I have installed Shelly 2.5 for lights, everything working fine. I have integrate Shelly cloud with Smartthings app, the only issue that smartthings app showing incorrect status of the device when I use the physical switch only. Fun thing is, when I have installed shelly 2.5 switch everyting was working fine bit after two days problem showed up. Is anybody have idea how to fix it?

Hi @Coolby, @Hiato I ask you, you seem to me 2 people who at least a year ago were very interested in this integration, is this still the case?
Why hasn’t Shelly implemented use with SmartThings locally and not cloud to cloud as it is now?
What I still don’t understand is if the will is lacking. I inquired and I see that Philips Hue allows integration with SmartThings locally, even the guys from Tasmota have developed an integration that works locally, and their firmware can be loaded on Shelly devices and work locally. Now I wonder then, why Shelly staff didn’t do it? I would really hope for this integration, the Smartthings community is very large globally and nobody is willing to invest in devices that do not work locally, this would be a great chance to increase customers in my opinion.
My electronic and IT knowledge is limited, I have informed myself and more people have confirmed to me that the current shelly firmware are adequate to be able to work locally on ST, what is missing is a connector between shelly and smartthings, as happens on Tasmota devices to understand each other. Do any of you have any more information to explain to me if I have misinterpreted something?
I would be very happy to find a solution to make Shelly work locally without having to install Tasmota Firmware and thus lose the use of the Shelly app.

(completely ignoring long technical description i wrote and deleted)

That woukd require HUGE technical changes by the device manufacturer that honestly is not in thier best interest from a business perspective.

Short version… Wont happen.

The landscape for this issue completely changes after the HA industry Project CHIP becomes a legitimate standard. Its in its infancy at the moment so we’re a couple years from that.