Sensi Thermostat

Unfortunately not. Broadcasting from the SDK is disabled regardless of location. They should hopefully be rolling a fix out by next Friday all going well

Hello folks,

I am so glad I found this discussion thread because I had been so frustrated last few days trying to figure out why all of the sudden my Sensi thermostat no longer runs on my ST routines.

So the fact that Sensi still works with Alexa skills then shouldn’t we be able to connect to the same API endpoint? I think the way that Alexa connects to Sensi is about the same as how Kirk’s smartapp does today is by connecting to Sensi’s API and authenticating with the Sensi user account.

I was able to temporarily Rube Goldberg my Sensi thermostat automation back together. But it’s a band-aid for now. You will need to setup, if not already, 1) Wink mobile app 2) Stringify (an IFTTT competitor) mobile app .

Sensi has a supported integration with Wink. Luckily, you are able to download and setup the Wink mobile app without having a Wink Hub. I linked my Sensi Thermostat within the Wink App, and setup a couple Wink “Shortcuts”, which are similar to SmartThings Routines, to mirror my Sensi Thermostat temperature settings. In my ST Routines, I have them trigger virtual momentary switches, for example; SmartThings Routing “I’m Back” -> Turn on Virtual Switch “I’m Back Fired”. Then I am using Stringify (a IFTTT competitor), to consume the “I’m Back Fired” event and trigger the Wink “I’m Back” Shortcut, which set’s my thermostat to temperature desired.

This is most definitely a hack, and gives me much less customization than I had before. I was using WebCore to automate my HVAC logic, recirculate air, fire SMS warnings upon various conditions, etc, and none of this is achievable thru this solution. However, for simple Routine based automation, this is a band-aid for now until I replace the sensi w/ my new Z-Wave CT101 thermostat. Unfortunately, Sensi doesn’t fit my requirements anymore without our ability to integrate into ST.

It looks like this can be achieved with SmartThings -> IFTTT -> Wink as well, instead of Stringify in the middle. Still requires the Virtual Momentary Switch to be turned on via ST Routine though.

Thanks for the info John, I’ve used all of them actually. And I actually moved from wink to ST because I simply don’t like the lack of functionality wink has (I didn’t have wink hub so all through wink app).

Back then I used Stringify for a little automation too but I found the app is to clumsy and not intuitive. IFTTT is good for the simplicity and abundant support for different services.

The fact that I really don’t like this way (it’s good suggestion of yours indeed) is this involves too many middle men already. I just want to keep connection fast and simple, adding too many in between is not ideal.

That being said, I am still curious how you can trigger IFTTT from virtual switch? I know how to trigger IFTTT using webCoRE which would save me one route of automation if it’s coming from it :joy:

My understanding is, all these connections (official integration that is) require you to login using their portal and authorization before using it. There’s a contract between these services and sensi simply opens up the API for them. Since SmartThings is not supported by sensi, we have no way to go through this process because sensi would not allow SmartThings to do so.

That said if we actually can figure out how to get to the authorization page, they may be a huge step forward.


Please read thru this thread to get a conceptual idea of a virtual switch

It seems like we should be able to sniff the traffic on the Sensi phone app which is still using the free service. We may find out they they simply changed the server name the app communicates with.

Hi Kirk,
Sensi changed the API for their thermostat, will you update the code for the SM SmartApp?
this is the answer i got from them:

Thank you for contacting Sensi Technical Support. We do apologize for the issue you are having. Here is the new link: We also want to inform you that the skills are not going to work with the updated endpoint due to the legacy API no longer existing.


Hi sir. I’ve been using the Sensi integration happily for a few months now, but about a week or two ago it stopped working. I tried a few things without luck, so I deleted my thermostat to try to re-add it. However the thermostat no longer shows up to be added.

I was curious if you were aware of anything breaking recently? If not, I’ll keep trying.

Thanks much!

Yes, unfortunately sensi completely redid their website API. And they do not make it public. I reverse engineered the old one. But this new one is beyond my abilities right now. Maybe you could email sensi asking for the API specs and access. Couldn’t hurt.


1 Like

Thank you for the reply, I’ll do my best to see if I can get anything useful.

This is getting so ridiculous from Sensi’s end that I sold both my thermostats…

Thanks for supporting us this far @Kirk_Brown

Contemplating posting mine on ebay also and moving on… I’ll email their support first.

So I assume this is officially dead? Was nice while it lasted. Stupid me just bought another Sensi.

Well seems like it, Kirk said he’s out of luck trying to get through it since they need official login authorization page to enable integration.

I’m just going to setup an IFTTT recipe for my webCoRE automation …

Slightly related to the API change… this week my Sensi thermostat started running schedules I never created. I now see a schedule for Cool, Heat, and Auto which have checkmark indicators and I cannot uncheck them. I did try to change the Schedule Type in the app to No Schedules… but it didn’t seem to prevent the mystery schedule(s) from commandeering the temperature. I sent an email to Emerson for help. Anyone else seeing this issue?

Not having this problem right now. But just half a month ago my thermostat and app started to act unsteadily.

From time to time it disconnected from my WIFI which it hadn’t been for over a year. Then I could not update the temperature and on/off status form my app, it often jumped back to some kind of default setting such as 25 cooling with schedule running (I didn’t let schedule run).

Then I tried pulling out batteries at the back and tried reinstalling it (like setting it up for the first time) and boom it started working again.

So you can try reinstalling it, or even resetting it. I guess their change to the new API hinders existing thermostat settings, shame on them…

Yes. This very thing is happening with my Sensi schedules. It’s quite annoying. I wasnt too worried because I figured it wouldn’t follow “Hear” or “Auto” schedule unless it was set to it, but it’s not following my “cool” schedule either.
Did you get any feedback from Sensi?

I haven’t heard from them yet. It looks like setting mine to “no schedules” did eventually prevent the schedules from running. Mine was running the cool schedule that had been created without my knowledge.

SENSI Thermostat Recall

Just received notification via Amazon:

Emerson Thermostats Sensi Smart Thermostat, Wi-Fi, UP500W, Works With Alexa

More details, including how to determine if your purchase is impacted and what you should do next can be found in the following notification:

If you made this purchase for someone else, please notify the recipient immediately and provide them with the information concerning these issues.