Sengled Element Plus Bulb - Can't adjust color tempurature!

I just added a Sengled Element Plus bulb to Smartthings. I can turn the bulb on/off and control the dimmer just fine. The setting for color temp shows up in the app (set at “Moonlight”), but when I try sliding it to adjust to a different temp, it snaps back to its original position.

Is the color temp setting for the bulb even enabled in the Smartthings app? The color temperature slider does nothing no matter where I try to set it.

1 Like

I think I have the same bulb (I don’t know how many model variations they have?); but had the same discovery.

My conclusion?

The bulb doesn’t have an independent color temperature setting!!! It is designed to have a “warmer white” temperature when it is dimmed (unlike a lot of plain dimmable LEDs which actually get “colder white” (harsher) when dimmed.

Actually, when used with the native Sengled hub, the bulb does have a separate color temp setting.

Demo video (video is queued to 2:29 where the feature demo starts)

I’m going to search around for another device handler for the bulb that will support this feature in Smartthings. If I can’t find one, I’m returning it and going for a more tested and proven bulb.

1 Like

For a custom z-wave device handler, you could start with the below source from the SmartThings Public area.

This uses a z-wave setColor comand with r, g, b = 0 and color temp based on a slider.

If you return the bulb, look for a Sylvania white with color temp or any zigbee bulb. SmartThings has significantly better device handler options for zigbee vice z-wave. I have the Oshram/Sylvania bulbs and they work.

Thanks, Dave. I’ll give the Osram bulb a try.

It is, but it’s weird: no matter what you choose on the slider, it increments up by a slowly increasing number. It started incrementing at 18 each change in Moonlight and now at Cool White, its at 23 to 26 K up per change. I altered the Device Handler so I could see the K on the main screen and not just the log and if you just keep sliding upward each time, you’ll get higher.

Note: this also works the same way lowering the color temp. I got to the highest point in Cool White and took a break.

I have no idea where the problem is; I read the code and checked zigabee references and nothing would tell me. I’m wondering if its a firmware issue in the lightbulb itself that reads any number as a proportional increase or something instead of an attribute change.

[quote=It is, but it’s weird: no matter what you choose on the slider, it increments up by a slowly increasing number. I
[/quote]

Could the bulb have a transition period that can be set through z-wave?? I have a wifi bulb that has that function. Allows the light to fade on/off, fade on changing color, brightness, or color temperature. (I did not place this in the device handlers I wrote, cool, but not that useful to me and other users expressed no interest.)

If set too slow, can really be cumbersome. However, if properly programmed it could gradually turn on light in AM to ease you into the day.

You might also check your preferences for the device. Some can set transition rates in preferences (i.e., ge bulb).

Maybe, but I doubt it. I removed both and added them back in with the altered Device Handler and added events to log all values coming in and out and no matter what value goes in, it increments up or down the same proportion (now at twenty-eight and twenty-nine). Either a command is missing somewhere or the firmware itself is using a default value whenever it gets a temperature command and I suspect it’s the latter; it’s probably something that having the Sengled Hub itself would fix. I’m sure there’s another way but I have yet to find it.

I am tempted to get the Hub; the Sengleds are brighter than my Hues and almost as bright as the LIFX and cheaper than both so it’s worth the investment, even if the Hues are more flexible. I’ll give it a few more weeks to see how these two perform.

What device type handler are you testing? I also have an element plus bulb is like to get working.

The standard one in the Device Handler area: zigbee white color temperature control. The only real change I made to my version that works is adding in the current temperature in the tiles and some new events to log in-out values; everything else I put back to default since it didn’t make a difference. I may be missing something in zigbee somewhere but as yet I haven’t found it.

Tell me if you get anywhere. I finally–after much incrementation–got both mine up to daylight and if the color temp can be controlled better, Sengled is a fantastic bargain for controllable lights. If I need the hub to do anything, not so much (though still good, just why bother when I have a good Hue infrastructure).

Apparently, the Sengled Element Touch (with the button) has color temperature support in SmartThings.

Currently $17.99 on Amazon. Going to give this one a try since the fairly comparably priced Plus model ($14.99) didn’t work out.

I swear I have this bulb, and yet the only way to adjust color temperature is to dim (is also becomes warmer) or brighten (it also becomes cooler).

Hmmm…

I think perhaps the wrong DTH was assigned by SmartThings. Let me try manually changing it.
image

OK… I changed to “ZigBee White Color Temperature Bulb” and now I get the Color Temperature Slider in the App … but it has no effect.

image

Perhaps I don’t have the compatible bulb (or still the wrong DTH?).

image

I tried the same DH and got the exact same result. The color temp slider shows up, but each time I try to adjust it, it slides right back to its original setting with no effect. I did try to see if adjusting the dimmer affected color temp, but it only becomes brighter with the same color temperature instead of becoming whiter.

Again, I think going with the Element Touch might be the solution. I’ll know for sure once it comes in and I’ve had a chance to try it out.

Hmmm… According to Google Search / Amazon, “Z01-CIA19NAE26” is the “Element Touch”…

I got my bulb working by using the ZigBee White Color Temperature Bulb DTH and the new “zigbee.setColorTemperature(Integer value)” API command. Here’s what the function looks like now. I commented-out the lines that are no longer needed. I don’t think the “value = value as Integer” is required but I left it in there for giggles.

def setColorTemperature(value) {
    setGenericName(value)
    value = value as Integer
    zigbee.setColorTemperature(value)

/*
    def tempInMired = (1000000 / value) as Integer
    def finalHex = zigbee.swapEndianHex(zigbee.convertToHexString(tempInMired, 4))

    zigbee.command(COLOR_CONTROL_CLUSTER, MOVE_TO_COLOR_TEMPERATURE_COMMAND, "$finalHex 0000") +
    zigbee.readAttribute(COLOR_CONTROL_CLUSTER, ATTRIBUTE_COLOR_TEMPERATURE)
*/
}

If you can wait until next week, there should be a fix for this going out soon. This would negate the need to use a custom DTH.

2 Likes

Don’t think the fix is available yet, is it? I still can’t make my sengled element plus turn to white (6500K)

Yes, the fix is in place and working using the default handler. I believe the DTH is ZigBee White Color Temperature Bulb.

My bad, I have just got the samsung connect and wasnt using the smartthings app but the connect home app. worked perfectly :):grinning: