Scout - Called by central station for false alarm, no notification in SHM app?

hubv2
shm
smarthomemonitor

#1

Just set up my Smartthings Hub with home monitoring, put up my sensors (7 open/close and 1 motion) and ran it in test mode for 6 days so my wife and I could get comfortable with it. We’ve never had a security system, so we have that learning curve on top of me tinkering with the setup.

I noticed during the test period that I’d get emails from Scout saying that they detected an alarm at my house and gave the script of what would happen if I was out of test mode. This happened in Armed (Home) which has all open close sensors on and no motion. Each time I’d get the email, the ST app would not give me a push notification or an alert that needed to be dismissed. There is nothing in the history, and everything is green if we open the app.

Tonight I signed the agreement and went live for Scout monitoring. Sure enough, I got a call that they had detected an alarm. The dispatcher said it was for my motion sensor. I provided the code and they ended the call. I immediately checked the app and verified that I was in Armed (Home) and that it was green. In addition, I have SHM set to have all my lights come on in the house when an alarm is detected (as well as my living room audio system at high volume on an FM station, until I get a siren). Nothing was triggered locally. Yet Scout got some kind of alert from the motion sensor despite me being in Home/Stay.

I went through SHM Security setup again and verified that Home was set to ignore motion sensors.

Any ideas on what I could be doing wrong?


SHM & Scout Bug
(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

What are you doing wrong? Well, to start, I’d say “using Smart Home Monitor and Scout for home security” :speak_no_evil:sorry… I couldn’t resist the snark… I seriously don’t think SHM is ready for commercial dependable use. Too many quirks in it and SmartThings itself.


#3

Always appreciate the snark. As for SHM/Scout, it meets my requirements:

  1. wife wants home alarm
  2. i don’t want to spend $40/m for monitoring
  3. if i have to do it to appease wife I might as well get something to tinker with that is cheap.

I have zoneminder and a mossberg tactical for my peace of mind, willing to pay 215/yr to make her happier though.

I got another call from them after walking through the living room at 2am. They put the motion sensor on ignore for 72 hours. I will see if I can figure it out by then.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

Try to keep a PC or tablet or something with Live Logging (login to your IDE / “graph.api” shard for SmartThings).

I don’t know how much debug logging the Smart Home Monitor SmartApp outputs, but it’s better than nothing.

Problem is that the login session will expire quite frequently. I don’t know an easy way around that.


#5

Well it’s pretty reproducible so that was very helpful. I just cleared the log and walked through the room with a motion sensor and copied the output from the SHM and Security tags. It does appear that SHM registers the motion as an alert of some type in the security log:

3:30:01 AM: trace onSecurityTriggerData([:xxxxx[[attribute:motion, value:active, timestamp:xxxx]]])

Not sure what is safe to paste from the log, so I redacted some addressish looking characters.

Thanks for the replies.


#6

Morning bump, I called Scout support and they had not heard of this issue


#7

Just to be sure, were you using SmartThings sensors? Or scout sensors?

And what did you mean by “ran it in test mode”? (“Mode” has a very specific meaning in a smartthings context.)

I would definitely contact SmartThings support and see what they say.

https://support.smartthings.com/hc/en-us


#8

I have 6 open/close sensors, 2 of which are smartthings v2 multi and 4 are iris open/close using a community device handler. Also currently have one Smartthings motion sensor in my living room. The test mode refers Scout’s professional monitoring. They are ignoring the motion sensor for the next 72 hours.

I did talk to Smartthings support today. The suggestion from the rep was to re-setup SHM and manually configure the toggles for each mode and sensor. I was using the default where it has the one toggle for all open/close and no motion for the Armed/Home state. I will be giving that a shot when I get home.

edit:

Tried the ST suggestion and the Scout suggestion I received by email a few minutes ago (completely removing the SHM app and setting it back up). Scout agent said that my app had an invalid token along with what else was going on, so they suggested the wipe. After both suggestions, I’m still getting odd output in the log.

Here’s the output for the Security tab in live logs for the motion sensor when I the alarm is ‘Disarmed’:
3:52:00 PM: info SHM isActiveSensor(motion:active, app: off, location: off) = false

Here’s the output for the motion sensor when system is “Armed (Home)”:
3:47:15 PM: info SHM isActiveSensor(motion:active, app: stay, location: stay) = null

And here’s the output for an open/close sensor when the system is “Armed (Home)”:
4:02:40 PM: info SHM isActiveSensor(contact:open, app: stay, location: stay) = true

Additionally after ‘correct’ reading, in Armed (Home) for the contact sensor, there is a security incident log entry generated under Security, as well as several lines generated in the Scout Alarm log:
4:02:50 PM: trace getSecurityFeatures()
4:02:49 PM: debug Post successful - dismissed intrusion event
4:02:49 PM: trace intrusionEventDismiss()
4:02:49 PM: trace onSecurityDismiss()
4:02:49 PM: trace getSecurityFeatures()
4:02:49 PM: trace getSecurityFeatures()
4:02:42 PM: trace getSecurityFeatures()
4:02:41 PM: trace getSecurityFeatures()


I have not called Scout again to see if they are still receiving intrusion alarms from the motion sensor in Armed(Home) but considering the log output is identical to the wee hours this morning I don’t have a lot of hope.


(Ron Talley) #9

You might have a cat burglar that is sneaking in and out during the wee hours of the morning. Have you checked the fridge for missing food? :slight_smile:

Seriously, I hope you get it figured out. Insurance Co. wants proof of professional monitoring services and I was considering Scout as they are dirt cheap. Really don’t need it with notifications going to 6 people in the house along with 5 Blinks and an 8 ch Owl CCTV. But, like you, it will fit my needs.


(Brian Harding) #10

Just trying to be helpful here, but I am not connected to Scout so I can’t help you there. I don’t know if there was any movement in your home at the time of the incidents, but it appears ST is working correctly as no SHM alert happened. Motion Sensors will detect all motion regardless of the state of ST. The SHM monitors the devices you have set up in the Armed (Away) and Armed (Stay) modes and gives You an intrusion alert and notification when any of these devices activate. When the Motion Sensor activated in the Armed (Home) mode it did not trigger an SHM intrusion alert. That is working as it should. Why Scout Alarm is registering as an event, I have no idea.
Secondly, I don’t know what is triggering the Motion Sensor - you might wish to move it to a different spot and see what happens.
I am wondering if this is one of the newer sensors, Could be as this is a new system.
Either way, you need to try to figure out what is triggering the Motion Sensor first.


#11

Definitely know what’s triggering the motion sensor - its positioned to monitor our living room/entryway.

I think the issue is that SHM sends all data to Scout, and Scout is basically set up for boolean values on sensors. And they are putting ‘null’ values in the ‘True’ column rather than ‘False’. Ideally SHM should assign a value of false to any sensor not set to be monitored, instead of ‘null’.


(Jordan P.) #12

Did you ever figure this out?


#13

Sort of. The ticket is still open with ST support.

Looks like the issue is that Scout does not recognize the difference between Armed/Away and Armed/Stay with Smart Home Monitor. If you have a device added to Armed/Away, Scout monitors it in both ‘Armed’ modes. The issue is that SHM does not trigger and alert you that the alarm has gone off because it is in Armed/Home but Scout is tracking a device from Armed/Away.

I ended up just removing the motion sensor from SHM entirely.

As I typed this, I thought I could probably do a little workaround with CoRE and a simulated motion sensor that’s tied to the real sensor. So the simulated sensor only gets triggered in Armed/Away mode. Obviously would require network and would have lag but this might work.

edit: set up the CoRE piston and simulated motion sensor. Did two basic pistons:

  1. IF (LR motion changes to active AND SHM is Armed/Away) THEN (set Virtual LR Motion active)
  2. IF (LR motion changes to inactive) THEN (set Virtual LR Motion inactive)

Figured this way if I disarm the system it will still turn off the virtual motion sensor.

edit2: One other frustration I have is that the Zooz motion sensor I have in the garage holds the “ACTIVE” status for about a minute after motion ends. Because of this, if I disarm the alarm, go into the garage to get something, and then come back inside and arm the alarm again, I will trigger an alert to scout but nothing will alert me in smartthings. Got a visit from some friendly police officers at 2am because I went to get some batteries but had left my phone on the charger in another room so I didn’t get the call. Just a heads up.


(Jordan P.) #14

Well that’s just crap lol. My motions only trigger on away. I can’t be home at night walking around, armed in stay mode and have Scout call me about an alarm. How is that even a thing? Why would I sign up for this if this is how it’s working? Broken for 4 months. Wow

Jordan


#15

Yeah, it is pretty lame. However, check the edit of my post. The workaround I described works perfectly.


(Jordan P.) #16

Yea I don’t use core, and for me that’s too much work to get something to work, that should already be working. Especially if I’m paying monthly! So I guess I’m not signing up for Scout. Once this is fixed, and if I’m still living where I’m living, lol. I will sign up. I would love to see the ST list of priorities, and where this is on their map to fix.


#17

Experiencing the same issues. In touch with support for debugging. Few weeks before, I contacted support to update my email address which they did and then I started getting few issues. The motion sensor or entry sensor won’t trigger the bulb on/off events sometimes, sometimes they are delayed by significance amount of time, IRIS keypad stopped working and always shows tamper and I started getting this posted issue and got 5-6 calls from scout in a day. Surprisingly, ST app didn’t show any intrusion events. I contacted customer support but the officer was not smart enough to figure out (or even redirect me to some other technical support within his team) and sent me a snapshot indicating my ground floor NYCE motion sensor has Security mode configured as Armed(Home) which was not the case. The only configured sensor was Basement motion and entry sensor. He reset the hub and routines from his side and asked me to do the same which didn’t help. I tried repairing the Z network but it didn’t help either. Then I removed the Location (FYI:pain in the ***) and connected all things again and it started working as expected (or maybe NOT because my scout subscription stopped due to removing of location and scout resubscribed my existing subscription and gave me 72 hours of test period which is weird). Yesterday night, I experienced the same (posted) issue and got 3 calls from scout. I am in touch with the support to dig in detail.


(Ryan Jackson) #18

I am having this issue as well.

This just started on Friday 04-07-2017 for me. When my SHM is in the “Armed (Home)” setting, internal motion sensors are sending an intrusion alert to Scout with all motion events. No intrusion alert is activated through the ST app, nor should it be, in this setting. I have all internal motion sensors inactive during “Armed (Home)” but for some reason Scout is reading ALL activity as an intrusion.

I have used Scout with Smartthings for nearly 4 months now and have never had this issue.

I contacted support for solutions.


#19

My scout trial period ended on April 9, 12.10 PM and I started getting calls from scout the same day evening so it seems that issue was never resolved by removing and adding a location. I haven’t received anything from the support team yet.


#20

Exact same problem here. Started happening April 8. We’d been using Scout with SmartThings for a long time, ever since it was first offered. Never had issues until now but this is annoying enough that we are just about ready to cancel service.