Schlage Link RP200 Light Module Zwave

Does anyone have experience with Schlage Link RP200 Light Module Zwave? I believe it is an older version or a hybrid of GE / Jasco 45602 but am not sure. I wonder if anyone has gotten ST to control a light connected to it. I bought two today for about $20 each on eBay thinking is worth that as a Zwave extender if nothing else. Your thoughts appreciated.

I have not been able to get mine to connect. The instructions are specific to the Nexia bridge. I tried double clicking the button on the module but the smart things app does not detect it. Have you had any luck since this post? Thanks!

Sorry, Just noticed your December post. I never did get a ST hub so haven’t tested the module with ST. I do have a Nexia at one place where the modules work. I also have a Staples Connect in my primary residence and these modules do not work with it either, despite their having the ZW3101 model number on them.

I was hoping ST would work because it seems a little more flexible than the two I’m using presently but guess not. The “standards” (zwave, zigbee, Insteon) all seem to be very loose guidelines. After reading lots here and other HA sites, it seems to get this stuff to work reliably you have to pick a company using an implementation and stick to whatever they decide to support. I guess we’ll have to wait for Google or Apple maybe Microsoft to come up with a true standard protocol that allows equipment to be interoperational between hubs or provide hubs that support non customized devices. I don’t know which is the hold up today. Loose standards or rogue hardware manufactures.

Home automation today reminds me of PCs in the early 80s. Lots of operating systems with equipment built specifically for those systems. So I decided I’m not going to be an early adopter this go around. I’ll just buy the bare minimum I decided. Maybe a company can make this practical in 5-10 years so that you don’t lose your investment in hardware if you pick the wrong horse today and want to switch horses in the future. Or perhaps it will just always be chaos like every TV, stereo, DVD and the like having its own mini operating system in perpetuity.

I tried to add Schlage Dimmer Zwave Lamp Module Rp200 and could not make it happen on Monday night. There was some extra system latency around 7-8pm, like +5-10 seconds, and some lost commands.

Has anyone ever been able to add RP200?

I’ve been able to pair two (just kept clicking a three count, and eventually they showed up after a while).

They work for a while, but then stop responding to commands. If I push the physical button or unplug, they start working again for a while. Have tried unpairing to no avail.


same here; worked when you pair them; give some time then they won’t work. will work again when you unplug it and re-establish a connection; then not again. z-wave repair doesn’t help either. also limited range on these units (20ft).
– not worth the headache; buy aeon if you don’t want the trouble of trial / error.

They have all been working for me over the past two weeks.

I made two big changes. I don’t know what caused them to start working:

  1. I moved to hubv2.
  2. Moving to hubv2 required me to delete and re-build the entire network of lots of devices.
  3. There may have been new hub software along the way introduced.
1 Like

Schlage RP200 Lamp Module.
The instructions say incandescent only. It seems to work on my LED lamp and dim them.
Does anyone know if using this on LEDs will cause a problem or break the RP200?
Are there any long term effects?

Also, had could not get it to pair using - Connect New Devices (from Menu) > Lights & Switches > Switches & Dimmers. There was no Schlage device listed there.

Tried Connect New Devices (from Menu) > Lights & Switches > Outlets > Schlage > Schlage Light Module > Connect Now > waited and waited, pressed the button on the Rp200, still nothing.

Finally Connect New Devices ( from Menu) > Connect New Devices (without specifying anything about the RP200 and it found it as a Dimmer Switch.

Hello - I have the ST and can’t seem to find the Rp200 anywhere. You said that you went to New Devices, Lights and Switches, Outlets, Schlage, Schlage Light Module, Connect Now. I can’t find that sequence on the Android app. Where did you find that?



I don’t remember if I used a generic device drive. I don’t see it, as you stated anymore in the new version of the application.