Schlage connect wont work unless the hub is touching it

This is my 2nd lock I have tried with the same results. I bought one new… it worked fine except for the z-wave feature, Contacted schlage and the are sending me a new one… I got impatient and went and got another new one today, and I get the same results… so 2 locks and the same results… I can get it to pair but will only work if the hub is touching the lock. I have a Leviton decora z-wave switch about a foot from the lock… and that is functioning properly.

Here is the process I have done…
Exclude lock Multiple times successfully (as long as the hub is touching it)
Add the lock manually by pressing the 6 digit code pressing 0 and wait for the green check… (as long as the hub is touching the lock its successful)
Unhook the battery and press exterior schalge button several times… then hold it while hooking the battery back up… I get 3 green check marks…
Reset hub… do a zwave repair…

Unless the hub is very close… I get that the lock “failed to update route”.

All other devices work just fine I just have NO range to the lock.

Hub is the new version 3… wired to Ethernet.
Both Locks I have purchased new are the Schlage Connect Touch screen BE469NX

Never had an issue connecting any other device except for this Lock! HELP!!!

if using the SmartThings (Samsung Connect) app, try installing the SmartThings Classic app and see if that works.

yeah I tried both… no luck

z-wave repair finishes with no errors?

That lock always comes back "Failed to update route " unless close… I have gotten it 3 feet away with full functionality… but its 50/50 if it works

try removing the lock and exclude it. reset the lock (once again), don’t add the lock back but do run z-wave repair and see if it finishes with no errors. run it twice. report back and we’ll go from there.

1 Like

The lock is completely removed and excluded and the z-wave repair was successful as it is if I have the hub touching (or Very Close) to Lock.

reboot the hub, add the lock back, run z-wave repair again and see if you get that error

First repair said “failed to read protocol info” on the lock but has not finished yet

2nd repair said failed to update route unless its close… then it comes back no errors… 2 feet away yields no errors… anything more and I get the error everytime.

I wonder if another z-wave device is causing routing issues such as the leviton switch that is 1 foot away. if you wanted to test by removing that switch from the hub (assuming it would not cause hardship by removing it i.e. you are using it in a number of automations) then run z-wave repair and see if you continue to get the error. If you do, then Ijust made you remove a switch for nothing and I would be out of ideas.

1 Like

I did try that… This lock was the only thing on the hub at one time and still did not work. I have started over (factory reset on the hub twice) and still no luck. As we speak the only zwave devices are the lock and the switch at the moment. the reason I put the switch in that location was to be a repeater for the lock.

I am at a loss. tagging @RBoy to see if he has any thoughts for you. with the holidays, who knows when he will be around.

also, open a ticket with ST support at

Thanks! I appreciate the help. I think I am missing a step and the lock is still in a “security mode” of sorts… as I have not run into this issue with any other z-wave device.

you put the hub in pairing mode first and then enter your 6 digit code on the lock +0

Yes… I always get it paired… but never works unless close.

Do you have any cordless telephones, usb 3.0 cords or other wireless devices that may be causing interference where the hub is located?


No, as a matter of fact I moved my Asus Wifi Router downstairs as I thought that would be the problem… Nope… I just installed 2 more z-wave switches in that general area and replaced the one next to the lock… all paired right away and work just fine. I have a small house so there should be no issue with range. I just can not believe that 2 brand new locks would be bad! I guess I will try one more and see what happens.

I think I have it figured out… I have my internet from the house beamed to my shop… and can you all guess what frequency band it uses… Yep, 900 mghz. So I brought the bandwidth down to 5MHZ and found a channel that seems to not interfere with the zwave stuff. Right now the antenna is on the roof right above where the hub is at… So I will have to move that to the far end of the house. So far all is working well and much more responsive. Thank you all for your help!!! I bet if I would have shared that tid bit of info you guys would have figured it out… but I didnt think I would matter… But once I took it off line… then everything worked! Merry Christmas everyone!


Thanks for the followup. I bet this happens to other people also, so this will help a bunch.

what is the equipment you are using to send/beam internet from house to your shop?

Also I suspect you moved the carrier from 900Mhz to 5Ghz?