Schlage Connect not communicating


#1

I have had my Schalge Connect deadbolt for a couple years now with no issues. It paired up flawlessly, even without bringing it within 10 feet of my hub.

A couple weeks ago, it became “unavailable” and stopped communicating with my hub. Initially, I ignored it, hoping that it might fix itself…no such luck. Today, I decided I would try removing/excluding it from the hub/network then re-adding it to the hub/network. Removal/exclusion seemed to have worked fine as I can no longer see it in the app. However, when attempting to re-add it to the hub/network, I get the following error:

“This lock failed to complete the network security key exchange. If you are unable to control it via SmartThings, you must remove it from your network and add it again.”

At the same time that I receive that error, it locates the lock and I can add it but the lock itself times out and indicates that it did not pair. In the app, I can see the lock but cannot control it.

I have tried this process (excluding/removing and re-adding) several times. I am thoroughly frustrated and discouraged at this point. Any help would be immensely appreciated.


(jkp) #2

Try rebooting your hub and running z-wave repair :slight_smile:


#3

I saw a thread about factory resetting the lock first then trying to re-add it to the hub/network…it worked!!!


#4

Schlage locks Can be fiddly to pair. So much so that we have a community FAQ for them.

Follow the instructions in Walter’s post 4 in the FAQ exactly, in exactly that order, even if you think you’ve already done some of the steps. ( this is a clickable link)

In addition, just to be sure, have you moved any zwave repeaters recently that were close to the lock?


(www.rboyapps.com - Make your home your butler!) #5

You don’t need to do a factory reset, better to just exclude it and then re pair it if possible. So

  1. exclude lock
  2. reboot hub
  3. pair it
  4. run z-wave repair.

The reason I say that is factory resetting the lock makes the device id an orphan in the Z-Wave controller. It’s always better to exclude when possible.


#6

I had already done the factory reset before you posted this message. However, I did exclude/remove the lock before performing the factory reset. It seems to be working fine now. Is there anything that I should check to confirm that I do not have any “orphans” or other issues?


(www.rboyapps.com - Make your home your butler!) #7

If you performed the exclude before the reset then you’re fine.