Schlage Century wont connect to Smartthings Hub


(Mike Hardin) #1

Is anyone having problems with this? The lock is not connected to the door yet, so I have it about 2 feet from my hub. I keep entering the 6 digit programming code, but smartthings wont find it. The lock is working as the 4 digit user codes turn the lock. Any ideas.


(Jason) #2

Did you try a Zwave exclude first? That is typically recommended with all Z-Wave devices.

Also I found this page, hope that helps as I don't own this device.


(Dale C) #3

I have this lock and it is awesome.

So is the problem you are unable to pair the lock with the hub? You enter the programming code and then 0 to enable the Z-wave radio on the Schlage so you can begin pairing and enroll the lock to your hub.

Once you have it included to the hub consider using a smartapp like @ethayer Lock Code Manager to do all the user code programming, it will make your life easier for managing the codes. But you have a lock that has some other special features so @RBoy has an enhanced Door Lock User Code Management that works great with his enhanced device handler. I personally went the enhanced route even though there is a small fee that gives me access to all the other special features like disabling the AutoLock by schedule or mode using @bravenel Rule Machine.


(Mike Hardin) #4

Yes, I enter the 6 digit code and 0. The lock has a flashing yellow light, but the smartthings app keeps spinning saying looking for new devices, but it never finds it


(Mike Hardin) #5

I'm not sure how to exclude the zwave. I got to zwave utilities and hit general device exclusion, but it just spins. I tried hitting the program code on the lock but nothing is happening


(Jason) #6

you would have to hit the 6 digit code and 0 while the hub is in general device exclusion. it may take a minute for the signals to go through.


(Dale C) #7

The order is important. Make sure to put SmartThings into inclusion mode "Things", "Safety & Security" , "Locks", "Schlage", "Schlage Century Touchscreen Deadbolt"
, then "Connect Now" . When you have the spinning wheel and "Looking for new device" THEN

  • extend the bolt on the lock and then perform the following -
    Schlage button - 6 digit code plus 0 and a green check or the red X (if not enrolled)

(Leonardo Mageste) #8

I have this problem, not sure if you were able to fix yours, for me the problem is that I never get the green light enrolling to z-wave.


(Garrett Snelling) #9

I'm having this issue too. Did you ever figure it out? What is odd is that it shows up in smartthings but the lock doesn't realize it, so it keeps pining the yellow circle, and then eventually does the red x. I can't control the lock from ST so it didn't work obviously. I've tried several times and keep getting the same results.


(Leonardo Mageste) #10

Hi.
for me the problem was that I had already added the lock before I rebooted
my hub. As Z-Wave protocol only allows to synch with one hub, for the lock
it was already synched with another hub. I followed the instructions to
remove the lock then added it again.

To reset the Schlage Keypad Lock with Lever Handle

If the lock was not discovered, you may need to reset, or “exclude,” the
device before it can successfully connect with the SmartThings Hub. To do
this in the SmartThings mobile app:

  1. Tap the menu
  2. Tap the Hub
  3. Tap Z-Wave Utilities
  4. Tap General Device Exclusion
  5. When prompted, follow the lock’s removal process:
    1. Enter your 6-digit programming code
    2. Wait for the device to beep three times
    3. Press the Schlage button
    4. Press 0
    5. The Schlage button will blink three times to confirm

After the app indicates that the device was successfully removed from
SmartThings, follow the first set of instructions above to connect the lock.


(Garrett Snelling) #11

Thanks. This was a new in box unit so sadly not my issue, but I appreciate the reply.


#12

Sometimes even the new in the box device has a previous controller ID loaded in it, either because it was returned or more commonly because it was connected to the test network at the factory. It happens.

Even More often, though, what happens is that an initial pairing attempt fails but does manage to partially update the controller information, and from then on no new pairing attempts will succeed until that controller information is cleared.

Doing a general exclude is one of those troubleshooting steps that is almost always recommended since it can't hurt anything and might help.

When you add a lock, the lock needs to exchange an encryption key with the hub. This often requires having the hub very close to the lock ("whisper distance")

With most of zwave, if you were too far away to exchange the encryption key, the lock just won't pair.

Schlage is unusual in that it will go ahead and pair even if the encryption key is not exchanged. This ends up with the a device which shows up on the things list but which cannot be controlled. This is why you see so many threads in the forums on "help, I can't get my Schlage lock to Work."

The best thing is just to start by doing the general exclusion and then use the following instructions:


(Garrett Snelling) #13

I just found this post from you on another thread and was about to try it! Thanks so much for being an active and helpful community member. I will give this a shot and report back.

Found this video to be helpful:

I called schlage after failed attempts and they determined it is probably a bad lock. I'm returning it and getting a replacement.


(Monte Montemayor) #14

Same problem. I enter the 6-digit code, it flashes yellow but never beeps 3 times. So I never get the oppty to enter 0. I have tried the Repair Network thing too. When I try to add a thing, and use manual, Schlage Century, it never finds it. Any ideas?


#15

This worked perfectly! Thank you for the details!