Trouble Connecting Schlage Connect Touchscreen Deadbolt to Smartthings Hub V2 in New App

I have a Schlage Connect Touchscreen Deadbolt with Alarm.

It was working fine with with old app. It didn’t migrate correctly to the new app, so I decided to delete it and try to start over from scratch.

Here’s the process to connect the lock.

Unfortunately, it doesn’t connect and I get this message.

It is added, but I’m unable to control it.

The batteries in the lock are new (even though it shows 0%). There are z-wave light switches about two feet from the lock, but just to make sure, I added a long ethernet cable and tried to pair the lock with the hub inches away with no success.

Any ideas?

The same thing happened to one of my locks after it went offline and i deleted the lock from smartthings. After factory resetting & zwave exclusion - it would only join insecurely in the new app, but did not control the lock. The only thing that worked was adding the lock in the Classic app. It joined immediately with no issues.

I installed two of these last weekend and I had similar issues. I worked on it for hours, tried the other lock and it went through fine. Turns out, one of the locks I had didn’t have the right guts in it, the instructions didn’t match the product and I had to exchange it.

When I worked on the one that DID have the right guts, I was having issues connecting. What I realized is the model names and descriptions of the lock don’t match up with the app. When I tried to add the lock manually in ST, I selected the device that had ZP in the model name for the Zwave Plus. I think the description is wonky or something there is why I kept selecting the wrong one at first. When you select the z wave plus device, it allows you to just scan the qr code and presto it connected perfectly for me.

As I typed this, I went to get a screenshot of the one I selected and it looks like the device descriptions have changed slightly because now NONE of them mention model numbers but I’m certain this was the one I selected:

They must’ve seen me trying to connect a bazillion times in the logs lol.

It may not be the same issue but this was the trouble I had a few days ago and how I fixed it. Ultimately I deleted the ST integration for the lock and integrated it through Ring alarm because it had more bells and whistles with the locks.

Thanks for the replies. After multiple attempts with resets/delets/exclusions, I was able to get it working with the old app.

I was having the same problem with the new app. I tried so many times but I couldn’t get it to connect to the Schlage lock. I gave up and called the technical support 1-866-813-2404. They walked me thru step by step. Don’t wait your time, call them. It only take a few minutes.

I couldn’t get anything to connect with my new wifi hub. Tech support didn’t help. Finally tried turning off “use smartthings hub” in the app. unplugging the hub and plugging it back in again then everything worked.