Schlage Century Connect lock not completely adding to ST (can see in log though)

Hi there.

I have a brand new Schlage Century Connect lock that is not completely adding to ST.

I put ST in pair mode and start the inclusion mode on the lock. The lock keeps reporting that it pairs, and I can see the device in the “live logging” section online, but the app never finds the device and the device is never added to the list of devices in the online IDE. But the complete name “Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock” appears in live logging and I can even see when I lock or unlock the door manually in the log.

I have repeatedly retried by excluding the lock and re-adding it. Every time the same thing happens, it excludes okay, then appears to re-include and again it appears in live logging but not in the list of devices in ST app or IDE.

I have also tried rebooting the ST box and repaired the Z-wave network. I just can’t get past the point of it appearing in the log but not in the list of devices.

Can someone please help? Is there a way to manually add a device? I don’t know what to put in the network ID field though. Thanks a lot for your help.

Unfortunately you can not manually add it. two bits of advice - bring the hub within 1 foot of the lock when pairing it and use the ST Classic app :slight_smile:

Thanks for the response. Unfortunately, I already tried bringing it really close and also refuse to use anything but the Classic App :slight_smile: Any other ideas? It’s so weird that the lock indicates it pairs every time but ST refuses to add it completely. I am starting to sour on ST big time. Instead of a stupid new app that is watered down in features that nobody wants, work on stability!

tagging @RBoy he always has great advice

1 Like

have you tried powering down your hub for a minute (removing batteries and power cord if it is a v2 hub)

Look like you aren’t the only one experiencing this issue.

I would suggest try this in 2 ways:

  1. Exclude your lock
  2. Restart the hub (power cycle it and not just reboot)
  3. Pair the lock (keep it close to the hub)

If that doesn’t work then do this:

  1. Exclude the lock
  2. Restart the hub
  3. Wait for 24 hours
  4. Pair the lock

I’ve written up more details about the second method here:

If that works then I would also recommend reporting it it ST support. I suspect there may have been some recent platform change which is exacerbating the problem, it would be worth reporting it to ST so they can investigate it. If it’s pairing it should show up in the app, there some sync issue.

Also tagging @Brad_ST

Thank you, RBoy. (I love your work and it’s why I won’t move to the new ST app yet! It still won’t work with custom device handlers, etc, right?)

I will try the second suggestion since the first set of steps didn’t work for me.

I appreciate all of your suggestions.

1 Like

The device handlers themselves work just fine exactly the same since they run in the cloud and not the app.

The only difference is the user interface. For some devices like locks, cameras, Keypads and power adapters won’t provide you with the same UI options to maximize the use of your device configurable capabilities. Once ST adds support for custom attributes hopefully it will help us bridge the gap.
Meanwhile many of the devices like motion sensors, humidity, temperature and other multi sensors do have almost full UI capabilities in the new app.

I believe this has to do with custom device handlers and the pairing process. Obviously not a longterm solution or even a workaround for all but if you can, I’d recommend pairing the lock before adding a custom device handler. Once the lock is paired, then publish and change the device handler.

Thank you, @Brad_ST. I have custom handlers like RBoy’s Z-wave Lock handler installed but I assumed when a new lock was paired that it would use the default one for ST Z-wave locks.

Should I re-assign all of my other locks back to the default handler and then remove RBoy’s handler from the IDE and then pair the new lock and then re-assign the locks back to the new handler if successful?

Before going to that extreme, can you try republishing the custom device handler and then try pairing the lock again? This seems to be a cache issue and that should evict the cache.

Thank you! That worked. I combined all of your suggestions and this made it work:

Exclude it using general device exclusion.
Unplug ST hub and remove batteries for a minute. Restart the hub.
Waited a couple of days.
Re-published RBoy’s device handler.
The lock was the first to report it paired successfully again but this time, the ST app also reported the lock.

It’s working properly now. Thanks to everyone!

1 Like