I can connect my Schlage deadbolt but not control it


(Miles) #1

I am reasonably new to ST. I have installed a Schlage Connect Century Touchscreen Deadbolt. Thanks to some of the advice here I was eventually able to pair it with ST (had to do the multiple General Device Exclusion trick) - thank you very much.
According to ST everything is fine. ST reports the lock status perfectly - when you lock or unlock with a code or manually it reports it just fine. But the problem is that ST doesn’t control the lock - e.g., I hit “Unlock” and it says “Unlocking” but nothing ever happens. And I have given it time - 10 minutes. Still nothing.
BTW - this was true when I used the default z-wave lock device and now that I have installed the custom device - Z-Wave Schlage Touchscreen Lock. Still no control.
I did a search, but all I came up with was folks who were having trouble getting it to connect. I didn’t see anything about folks having trouble getting it to remote unlock once it was connected. Am I missing something obvious?


(Michael) #2

I have had a Schlage lock for the past year and it works great. I am able to lock and unlock it just fine. You may want to email support.


(Walter Edwards) #3

When you paired it did you get a green check mark on the Schlage Key pad? When you did the exclude did the phone say one item excluded successfully? Did you get the hub within 1 1/2 feet of the look when you paired it?

When you paired it the last time did you do a reset by by disconnecting the battery then connecting while holding the Schlage button, then a cal, then an exclude then a pair. This has worked well for me the last 3 times I did it. Make sure the hub is with in 1 1/2 feet of the lock. Must be done in the door.


(Miles) #4

First off - thanks for the responses.
To answer the questions posed: When I connected it I did multiple general excludes over a period of an hour or two, and then paired it. I did get the green check mark.
I did NOT put the hub within 1 1/2 feet of the door. I don’t see how that would work - the ethernet cable between my router and the ST hub is not very long. Certainly not long enough to carry it to the front door.
But would that be the problem? I mean - the hub does “hear from” the lock, since it reports the status correctly. Could it be having trouble getting a signal to the lock? If so, would having more z-wave devices in my network help? I only have like 3 right now and none are near the lock, but on Monday I am adding like 20 new GE light switches including ones right next to the front door.
Thanks again.

  • Miles

(Elijah) #5

When i did my replacement Schlage locks, they set up fine and worked fine, however it seemed to take like an hours for them to be fully functional in ST. I have one that was set up over 30’ from the hub, did fine.

keep in mind these were brand new model versions direct from Schalge to replace ones from Amazon that had keypad death


(sidjohn1) #6

Assuming they are all zwave, your zwave network will be much more stable after installing them and your lock should work better. You may need to un/pair the lock after you add all the switches and run a zwave repair.


(Realy Living Dream) #7

That is a nice thing about the V2 with battery backup, you only need a 50’ cat6 cable, not a Cat6 and a 50’ extension cord to drag it around the house pairing things that can’t be moved. Be even better if it had battery backup and WiFi .

Definitely sounds like a connection/ pairing issue though. If you get your ZW switches installed and still have issues, try repairing your Z-wave network through IDE , or removing and repairing the lock again with the switches in place.


(Miles) #8

OK. I will wait until the switches are in place and then give it another go.


(Walter Edwards) #9

Not sure why, but I had that kind of problem until I got the hub that close. I got a long network cable(80 ft), got the hub 1 1/2 feet away from the lock and it worked. Hub not that close, did not work. Just letting you know what I was told and what worked for me. Once paired no problem. Your mileage may vary. :wink:


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #10

I actually uninstalled my lock and carried it to the Hub (insert reference to Mohammed and mountains here?).

If you do this, it’s important to note that this lock self-configures for bolt direction, so you can’t reset and pre-configure without accurately simulating the installed orientation. I learned that the hard way too.


(Edward Pope) #11

I was going to say this is what I did to make it work. It did almost the same thing for me, but I also did not have a battery status from it as well. I removed it from the door, dragged it close to the hub, excluded and re-paired and it has been working like a champ since.


(Walter Edwards) #12

I tried that. The bolt had to extended. I did not get that to work. I used the 80 ft network cable. Had lock in door, that worked.


(Michele Harrison) #13

I had this exact problem. If I manually unlocked the lock, I would get notifications; manually lock it or press the button, get notifications (I am using the RoyBoy SmartApp and Device Handler). The lock was stuck telling me that the lock was unlocked even though it was locked. I removed the battery pack and put it back in, the lock was now reporting the correct status. I STILL could not lock/unlock the lock from the app (meanwhile the laundry room lock was working flawlessly).

Battery status on the laundry room was 85% and front door was 83%. I replaced the batteries and it was report 100% and the lock was again responding to the app.


(Nick C) #14

Same problem here, i could lock/unlock from app for about 1 week before that stopped but I could still see the lock’s status. I unplugged the lock from it’s battery source and nothing improves. What exactly did you do to be able to lock/unlock from the app?


#15

After perfect functionality for over a year, something happened where my Schlage lock and Cree bulbs stopped responding. I tried removing the devices multiple times and couldn’t get the hub to find them again. Finally, I moved the hub 10 inches further away from my router (it was originally about 1 1/2 feet away from router) and the Schlage and Cree bulbs started working perfectly again. I kept testing this by putting the router back to its original location, executing an action in the ST app, and repeatedly saw no response until I moved the hub further away. I’ve got the hub currently 10 feet away and so far all devices are responding well.


(Nick C) #16

My fix was even easier and so stupid in hindsight. I have 2 wifi networks in my house, a 5G and the standard speed. All my devices are typically connected to the 5G. I had noticed that the 5G had lost access to the internet but my devices were stable to connect to the network. I noticed this because my cell phone would connect to that network but couldn’t access the net. A simple restart of the router fixed it.