SCHLAGE Camelot


(James) #1

i recently purchased a schlage zwave lock, it worked great for a few days but then the touch screen stopped working.
the zwave all still functioned and i could lock/unlock remotely.

i exchanged it for a new one because it wasnt cool that the kids couldnt unlock the door when they got home from school.

the exhanged model looked slightly newer and mentions nexia on the box.

the touchscreen works and the device was included by the controller but it will not lock or unlock it.
i excluded it and factory reset it numerous times but it will not lock/unlock.

so i exchanged it again and the replacement is doing the same thing. i can see it includes successfully, the IDE shows it sending the unlock code but no response. the funny part is that when i create a user code for the door the and then check the “recent” tab in the app on my phone it can see user code 3 and usercode 4 created. so i know its talking but for some reason it wont lock / unlock.

the hub is about 10 feet from the lock, but i have several switches in between them for lights etc.

i dont want to exchange it again… hoping someone else has had this issue? or is it possible that the new model is doing something different?


(Dan P Parker) #2

Are you able to lock/unlock it via the keypad?


#3

Try the FAQ, it works for most people, but you have to follow these steps exactly. (This is a clickable link.)

A zwave lock will exchange an encryption key with the hub when it is first paired. Most models will say that the pairing failed if the encryption key is not exchanged successfully.

The schlage are unusual in that if the encryption key is not exchanged successfully, they will still say that the lock paired. It will work from the touchpad but the network will not be able to control it because there is no encryption key. Very frustrating.

But if you follow the steps in Walter’s post exactly as written, you should be able to get it to reset and try the key exchange again.


(Realy Living Dream) #4

Which device type are you using for the lock ?

Grab an extension cord ( or batteries) and a long LAN cable, Sit hub right next to the door. Then do a repair/replace of the lock. Leave the hub right next to the door run it through locking unlocking with app several times until you are happy that it is working properly. Then put hub back where it belongs and do Z-wave repair. Run the lock through paces again.


(James) #5

yes it does lock/unlock via the keypad


(James) #6

im using zwave lock, i tried using zwave lock with codes as well but it didnt help.

ill try again with the hub right at the device


(Dan P Parker) #7

I’m not sure I follow this. When you added the device using the ST app, did you select the “Schlage Camelot Touchscreen Deadbolt”, specifically?


(James) #8

yes i select “Schlage Camelot Touchscreen Deadbolt” but it is detected as “Z-Wave Lock”, when looking at it from the IDE i saw there was also a “Z-Wave Lock with Codes”, so i tried it as well but it didnt change the outcome.

i have now done as described above, moved the Smartthings hub to within 2 feet of the lock, ive tried the replace function where smartthings then says “device not considered failed”, and i have done an removal and a general exclusion several times.

every time i try to re add it… it pairs successfully but then wont communicate with it


#9

Follow the steps in the FAQ exactly. Don’t skip any even if you think you did it before. That appears to be the only sequence that will get the Schlage lock to accept the encryption key on a second pairing.


(James) #10

i followed them exactly. this sure is frustrating.
ive actually done it several times now.

the frustrating part as i mentioned above is that when i add a user code via the touch screen. ST sees that in the event log. so to me that means it is paired correctly.

he device however does not respond to polls or to lock/unlock codes and always shows as “locled” in the ST app.


(Dan P Parker) #11

Then I’m at a loss…sorry. My Schlage Camelot works perfectly. It’s certainly possible for you to get multiple units on exchange that are defective in the same way, but it seems a bit unlikely.


(Realy Living Dream) #12

Just because ST sees that you added a code to the lock , does NOT mean that Hub & lock properly exchanged the encryption codes that the lock requires before it will allow ST to lock/unlock it. Even if the code was not exchanged ST may be able to see it locked /unlocked ,although not always, but without that proper encryption exchange the lock’s security will not allow Hub to control it.


(James) #13

my hub is v1… is there any chance that a v2 hub would act differently?


#14

I use the schlage camelot on a v1 hub and have not had a problem with it for over a year now.


(James) #15

the first one i had worked fine until the touch screen quit. the newer one has a X at the end of the model number. its the one im having an issue with.


(Doug) #16

I just had to replace mine as, after 2 years, the mechanical mechanism died - it wouldn’t lock from the keypad or network.

As stated above you need to have the hub and the lock very close. Go through the remove (and force remove if needed) to get it out of ST. Need to do a reset of the lock, too, to make it forget the network.

Then start over.

Actually, the method I use it to include it in the network standing right by the hub and THEN install the lock in the door after I know that it is properly included. And then a z-wave repair - letting it run for 15 minutes until it finishes by itself.

I would also call Schlage support - when I was working through my lock problems earlier they were very knowledgeable and helpful.

Good Luck!


(Mcvoss) #17

Doug, I hope you used your warranty to replace. We have 3 year warranty on that lock.


(Doug) #18

Yes, I did! Sorry, should have mentioned that part of the excellent support.


(James) #19

well i returned my unit and got one of the older ones that they had. the only cosmetic difference i can see is that the buttons on the touchscreen light up white, where the newer one they were blue.
anyways this time there was no voodoo magic, it was included first try without bringing the hub close to the door and its responding to my phone via ST perfectly.

so i dont know why the 2 newer (nexia) units gave me the same trouble where the older units worked right away.
i just hope the touchscreen doesnt crap out on this one.

thanks for all the replies.


(SimonS) #20

I have this exact same problem - when first installed the lock, it would give me this “security error” and not pair properly. Did a factory reset of the lock and it paired right away - with the proper device type recognized. Lock worked every possible way.

Next day, I click unlock from ST app and “Unlocking…” was stuck there for minutes. However, when lock is manually locked or unlocked it reports right away back to the hub. Tried factory reset and re-pairing multiple times - security warning - fails to properly pair.

So I followed the guide exactly, brought the hub next to the lock, even killed circuit breakers for near by device and it paired OK. Again, 100% functional including lock/unlock via z-wave. 1 hr later - same story - lock/unlock via Z-Wave doesn’t work. But manual operation is reported back to hub immediately.

Any thoughts?