Schlage Camelot Locks - Totally Broken?

Between two homes I have five schlage Camelot Z-Wave locks. It appears they have now all been converted automatically to an edge driver. And none of them works. Some show incorrect lock information, some show no information at all, and none of them will operate through the app in any capacity.

I have so far tried excluding and reincluding one lock as a sort of reset. That did not work and for that particular lock I now get that it is not updating information.

Any help or tips would be appreciated.

try installing @philh30 Z-wave lock PH edge driver and changing to it on the lock.

Channel Invitation

if that does not resolve the issue… provide the model number for the lock and the fingerprint for it.


And if the lock(s) supports S2 security, be sure to configure it by either adding the locks using the QR code or manually entering the DSK when prompted.

Thanks for response, but no luck. I enrolled my location and installed both the regular and beta driver, but nothing shows up when I try to switch drivers in the app.

My locks are model #: BE469IR

How would I know if the locks I have are S2 or not? Google doesn’t seem to be know when I search on the model number: BE469IR.

use the Advanced web app

Ok, thanks for that tip! Well I see nothing there about S2 security, I did get some diagnostic information there when I tried to switch the driver. It seems to think my lock has the wrong fingerprint for the driver. I guess mine is not supported?

Supply the manufacture code that you can find in the same interface for the device.

Tagging @philh30

Using the Advanced Web App, look for the Manufacturer Code which will look something like 003B-6341-0544. Grab that code for each of your locks. If the code shows as 0000-0000-0000 for any of your locks, then you’ll need to re-onboard that lock so that it pulls in the right fingerprint.

Quick search shows that that’s the Lowe’s Iris model. Those are old enough that they should be the S0 models.

I think when you exclude these you also need to do the lock’s factory reset procedure before you re-include. With the S0 locks, you need to include with the lock and hub within a few inches of each other.

You shouldn’t need to exclude/include any of these unless the fingerprint is all zeros. Though you may need to repeat the process for the one you already excluded if you didn’t factory reset and include at extremely close range.


Thanks Phil, the manufacturer code for the lock I’m working on right now is: 003B-6341-5044. I’m getting that same error message about an invalid fingerprint when I attempt to assign the custom driver to the lock.

Any other ideas? I’ve got five of these locks and I really need to get this working.

That fingerprint is in Phil’s driver so it should match.

  - id: "Schlage/Touchscreen/2"
    deviceLabel: Schlage Door Lock
    manufacturerId: 0x003B
    productType: 0x6341
    productId: 0x5044

Hi Guys,
This morning I discovered that I had the same problem as Jeff with my Schlage deadbolt lock. I found this thread and followed your conversation. I applied your solution. I excluded the device, factory reseted and re-inserted the device. Everything went back as normal. I just had to re-add the codes in my lock and re-add my lock in the scenes and automations where it was used.
Thanks to all for your inputs


Alrighty then. Factory reset it is. I’ll give that a go right now and report back.

Yep, that did the trick. When I re-added it to the network it automatically selected Phil’s driver. I’m all set! Thanks for the help!

1 Like

For anyone in the future who might navigate here. The fix for this issue is to exclude the lock from your smart things, do a factory reset on the lock, then reconnect it. You will then be able to select the appropriate driver or in my case it will be selected automatically for you. The factory reset of the lock seems to be important.