Updates to Ecobee Thermostat through scenes has stopped, manual changes directly to device work

Here is a strange one for you. For years, I’ve had smartthings updating 2 ecobee thermostats without issue. With the latest geopresence issue, I tried out using Apple Homekit (through a homebridge plugin) and it also worked. As the 15.3 iOS update, geopresence resumed working so i decided to terminate the homebridge and return to using the smartthings app completely. Here’s where the strangeness begins…

I can update the ecobee thermostats IF i open the device in SmartThings and change the temperature manually. However, the scenes don’t change the values if i run the scene manually or kick off the routine.

To fix, I’ve tried rebuilding the scenes and routines. I’ve deleted the Ecobee integration and devices and reinstalled the ecobee service and devices. I know it’s connected because i can manually change the heat/cool setting in smartthings and see them update on the thermostats. However, I just can’t get the scenes to update the thermostat.

Any ideas?

I have the same problem over the last couple of weeks. Very strange, illogical behavior.

  1. Ecobee App works. change either temperature, thermostat changes.
  2. Smartthings Ecobee thermostat device works: change either temperature, thermostat changes.
  3. Google is connected via Smartthings. Change temp in Google->changes Smartthings device-> changes Thermostat.
    4! ST Scene works. Change temp via Scene-> changes Smartthings device -BUT- does NOT change Thermostat!! #FAIL.

How can this be?
a. change ST device → changes thermostat
b. change google → changes ST device → changes thermostat
c. run scene → changes ST device -BUT- does NOT change thermostat!?

The device works

  • when invoked manually
  • when invoked by google

Does not work

  • when invoked by scenes?
    I have deleted the scene and recreated it to no avail.
    I did notice the Device data in the IDE it’s a little weird too as type “placeholder”

gtc100, just trying to self diagnose here. Every device has a device network IDs except for Ecobee devices. I think this happened during paring (or the lack of assigning device ids. Do you have device IDs assigned (to rule out that on my end as a possible cause)?

Interesting. my thermostat’s network ID: ecobee|:nikeSmart-thermostat|:undefined
Should I blank that out?

I am baffled that

  • ST can control the thermostat from the device.
  • Google can control it via ST.
  • Scenes change the device, but not the thermostat itself

I just used Device Logging to confirm the above!
All temp changes show an event at the Device!
Only the last one, via Scene does not work on the thermostat!
Of course, you know 1st line supports response, remove and reinstall…

So I reached out to support, not expecting much but immediately got a knowledgeable person to chat with. She was able to work with me to confirm the issue and told me she would escalate to the engineering dept. About 24 hours later, someone called me on my cell to ask me to generate some logs so the dev team can look at it. That was about 48 hours ago. I’m still optimistic that there is work happening behind the scenes due to the engagement so far. Will keep you in the loop in case I get any solutions.

Wow! That’s great

I asked for my case to be escalated per yours and a supervisor wrote back:

“I would like to inform you regarding this case. We are aware of this issue, our developers are investigating and working to fix this at the earliest.”

Great sounds promising!

I also inquired on my ticket and got… “ We’re working with ecobee on issue and still waiting on an update”

So sounds like they have replicated it.

Any further news regarding a software patch/fix? Driving me nuts that the scene runs everything except changing the thermostat temperature. It worked for years - what changed!?

I hear ya as it’s driving me crazy. I just asked for an update and they asked me 2 things.

  1. To provide them the date and time of when the scene failed. I ran it again, it failed of course, and I gave them all the info asked for.
  2. They asked me to contact ecobee which is the first time I heard that.

Due to number 2, I suspect I see where this is going which is frustrating and disappointing after this working for years.

I used to have a honeywell thermostat and it worked flawlessly too, at the time. I wonder if this issue is isolated to Ecobee and Smartthings interfacing (maybe honeywell or another thermostat interface will work)? As the temps are getting hotter in FL, now is when i would start to see a savings with the scenes when we are away from home. Unfortunately, that isnt happening because this issue has gone unresolved.
It’d be great if Smartthings/Ecobee would develop a fix and answer this thread directly so that all of us can get back to baseline.

Updates? Anything new? Hoping for a fix, and quick!

Have you received any updates? The problem persists

1 Like

Smartthings hasn’t really been very responsive. They have been when ive escalated the ticket but then it goes quiet. The last i got on Mar 22 was “We have reviewed this behavior with Ecobee and escalated it to their engineering team to conduct additional testing. There is currently no ETA on a fix for this since the issue is coming from Ecobee’s end. We are continuing to work with Ecobee regarding the issue.” But nothing since.
Today I’m working with Ecobee support to see what they could see on their end. Will keep you in the loop.

Ok, your not going to be believe this… it appears im fixed after only about 10-15 min with Ecobee support. My automation to simulate im not home that wasn’t working were the following settings…
Cooling Temp: 81
Heating Temp: 65
Fan Mode: Auto
Mode: Auto
This didn’t work for automations.

Ecobee asked me to change the Fan Mode to “off”. My new settings that worked were…
Cooling Temp: 81
Heating Temp: 65
Fan Mode: Not Set
Mode: Auto

And abracadabra… the automation worked. Try that on your end.


It absolutely worked for me too, just the way you wrote it. Thanks for working through it with Ecobee - this is going to help a lot of people!

Amazing, this has bugged me for a while but it’s fixed!

Thanks! This has been bugging me forever!! I wasted hours troubleshooting this and finally recreating all my scenes by using ROUTINES instead with temp changes inside - that’s probably why they worked, because I wasn’t changing the FAN MODE when setting temps manually in Routines.

Any updates from Ecobee @flgator ?

Man, I wish we could just control our Ecobee’s locally with an Edge driver.