Samsung TV “offline” when powered off

This is a long-term problem that I’m having, that has only recently begun to really bother me. Samsung TV model UN58MU6100. It shows as a device in ST and I am able to power it OFF via automations and WebCoRE pistons… but if the TV is physically OFF, it shows as “offline” in ST and therefore I cannot turn it on via automation or pistons. In ST Facebook group, I was told that the ‘On With Mobile’ needs to be turned on in the TV settings> Network> Expert Settings… but this option doesn’t appear there. I was also told that the TV needs to be WiFi connected (rather than Ethernet) so I switched to WiFi, but not getting any other love that way either. Any other things I can try to make ST “see” my TV when it’s off?


Your only option is a total TV reset and there is still no guarantee that that will work unfortunately

Unless the TV supports s as listening mode when off it doesn’t listen to the network and hence cannot be turned on remotely. Does your model support the ability to listen to remote signals when off?

after you switch it to wifi, do a total reset and re-add to SmartThings app.

@RBoy , I’m not certain of exactly what I’m looking for, but I don’t see anything that sounds like that

@prjct92eh2 , Thanks- yeah that’s the nuclear option because it’ll mess up a lot of pistons and automations- but I don’t see any other options at this point. Thanks

On further thought, maybe it’s not too destructive because I was thinking it’d screw up all my Harmony remote activities… but I’m now thinking they’re unrelated and won’t be disrupted

You may want to check if your TV model supports WoL or WoLAN.

also check to see if there is a firmware update.

dude, I hope you haven’t done a nuclear reset before you’re reading this…

im having same frustation since several years ago with my 2016 smarttv with no offical answer, the only solution was creating a webcore piston using the integration between Google Home and Smartthings through cast-web service:

I mean, using this piston “awakes” my tv sending a “empty” speak-text command to the TV:

But because this causes the TV awakes on “casting mode” i need to change the HDMI input: thats why i firing on same piston a virtual switch as “witness” what im using on a simple automation routine on the smartthings app to change the HDMI input everytime this virtual switch changes:

Of course, this is not the ideal thing but it has been working fine…hope it helps