Samsung TV always offline in ST when turned off

Hi! I have a SAMSUNG UE 65 TV. I used to connect with ST even if the TV was turned off. I could turn it on or off via ST (I use a Samsund S9+).
Now it is impossible. As soon as I turn my TV off, it appears offline in ST.
I have tried almost everything: Ethernet or Wifi. Reset the router. Remove the S9+ from the device list and reinstall. Restore the TV to factory settings. Deleted and re-added the ST app.
I even connected the TV over the mobile hotspot of my S9+ in order to exclude any issues of the router.
But everytime I switch off the TV it goes offline in ST.
I called Samsung, they couldn’t help.

I bought one new Samsung N4300 (2020) and don’t turn-on with the app (or ST)
When I turn-off, after one minute the tv disconnect wifi and I have the option “turn on with mobile device” select …

This is an old problem that Samsung don’t fix …

Its an age old issue, with plenty of lengthy posts on the forum, the issue did get resolved eventually in the old app but since the advent of the new app and the new echo integration the issue has resurfaced, recently my UE65 now has a live on off button even if the TV has been off for hours, however on is still not available in an automation and most of the inputs are missing as well

After reading this post, I decided to try my Samsung TV again. Used to work in Classic app before new v3 app. Than Samsung made all of changes, and merged many apps into Smartthings app, and TV become disconnected, or I could not turn it on with app but once was turned on with remote I could use Smartthings apps for full control.
It’s one of those curved TV, more specifically UN65KS8500. It is connected over LAN to router.
Today somehow even that is showing that is off/offline, on/off button is available. If I press on/off button, it turns TV on and shows TV is Offline notification, but TV is turned on and it can be fully controlled.

However in Automation only Off function is available for that device.
@jody.albritton is this connected to new firmware with local status check? If it is, it’s goi6in right direction, however some DTH need update.

Yes, I have a separate post about this a few weeks back.
I have had to change my WebCore pistons for that room to check for “offline” now. Thankfully I don’t need to turn the TV on or off remotely.

Has anyone got a fix for this? I’m still getting it

Also have this issue, but it seems to be the case on the ‘older’ Samsung TV we have circa ~3 years old.

The newer one we have, that always stays connected, even when powered off via remote. :man_shrugging:t2: