Samsung TV - Can't Turn On

Seems this is no official fix for this. Seems that the TVs function on the new API but are exposed to google/alexa through the old api as a switch which does not do anything.

I’ve been using the to turn the TV on which works via google home (sometimes you have to ask twice) but not further control is available. However, It can be fully controlled via the new (connect) app.

Google says that It’s a Samsung Issue and Samsung Says it’s a google issue, Apple is fuc***g smile

1 Like

I have a 2019 Q70R TV and have similar issues. Smartthings app allows me to control the TV – on, off, change channel, etc. Alexa discovered the TV through the ST skill but commands do nothing. Alexa replies “OK” but nothing happens.

I also noticed if I try to create a scene in ST to turn the TV on or off the scene does not work. I thought if exposing the scene to Alexa but it doesn’t even work in ST app.

I’m having the same issue with my Q70r.

I can control my TV when it is on and I can turn it off. As soon as it’s off though it can’t be controlled through the SmartThings App or Alexa.

I’ve spend hours on the phone with clueless people who struggle to understand the issues then just tell me maybe it’s not supposed to do that - or that the issue is because I am using their app an iPhone. What a joke!

I should also not that the TV does wake up for AirPlay so it’ve very obvious that SmartThings is the issue.

It’s infuriating!

My workaround is to turn on my Samsung TV with my iPhones mirroring function and everything else with my google home mini.

Just turn it on using your phones mirroring function… I use an iPhone

I’m having this same problem, and I’m wired. So it’s not just wifi.

Have you read the post? I’m asking just because everyone can turn off and on the tv on wireless but can’t turn it on via cable lan…

Not sure if you’re talking to me, Richiczan, but if you are, I’d encourage you to make sure you know what you’re talking about before inferring others haven’t read the thread (which could be interpreted as you being condescending). Yes, I actually read through the whole thread, and what you are saying is absolutely not correct. Several users didn’t even say whether or not they’re on wireless or wired, and several have reported having this issue on wireless. In fact, at least one has said that they didn’t think about trying wired yet, which is why I made a point of saying that I’m on wired. I’d encourage you to re-read the thread more carefully. One example is:

"Same problem here. In troubleshooting I did a continuous ping to the TV after turning it off, and after a few seconds the ping starts to time out. So it definitely seems as if when it goes to standby mode the Wifi component is shut down.

Mine is connected to Wifi. I tried the Wake On LAN as well which failed but I never thought to try Wake On LAN with the TV connected using ethernet. Anyone tried this?"

Not only mine is working fine on wireless, but not on lan. And for all the majority the problem is on lan, if you split all the comments you will see that the workaround is to switch is on wifi.
So have you tried on wifi to see if it’s working? or you will tell me is not working on lan again ?

here is the official answer from smartThings support:
Hey Richiczan,

Thank you for clarifying, that’s super helpful. Unfortunately, the problem is that the TV model you have doesn’t currently support “wake over LAN”. What this means is that once the TV has been off for more than a few minutes, you wouldn’t be able to turn this back on via the SmartThings App. The only way to get this working is to connect your TV wirelessly to your home router.

We do apologise for the inconvenience but at this moment in time, we wouldn’t be able to change this but if there are any updates, customers will be informed!

Best regards,

I’ve been fighting with this issue on my own for awhile and just found this thread. While my end goal is to control my TVs via voice with my Echos, I don’t need to involve the Echos at all to reproduce the problem. All I need is the SmartThings app on my phone.

5 minutes after turning off my TV (which is using wired networking), the TV tile in the SmartThings app shows up as disconnected (a cloud with a line through it). At this point, using the Scene I created in the SmartThings app to turn on the TV does not work. Running the Scene just displays an alert that says “Family Room TV On ran, but some devices didn’t work” I also can’t turn the TV on using the TV’s tile in the SmartThings app (cause the power button was replaced by the disconnected symbol).

The interesting thing here is that even though I can’t turn the TV on via the Scene or tile, if I drill into the tile and go to the “Remote” screen for the TV, I can use the power button on that screen to turn on the TV. I have no idea why I can’t remotely turn on the TV, yet I can use the virtual remote (remotely) and that can turn on the TV. Very strange.

After reading this thread this morning, I decided to test out the wired vs wireless settings. I only had time for one test before going to work today, but I was able to turn on my TV using the Scene when the TV was set to use wireless, after the TV had been off for more than 5 minutes. I’m at work now, hours later, and the TV is showing up as Off in the SmartThings app as opposed to showing up as disconnected, so I’m hoping this means it’ll work. Fingers crossed.

Even if using wireless does address this particular issue, this is quite annoying. I ran wired networking to my TVs during my remodel last specifically so I wouldn’t have to deal with wireless. Given that Samsung can turn on the TV (even if using wired networking) from their app by using the virtual remote, it seems like they really should be able to make Scenes work. Just provide the option to use the virtual remote power on/off in Scenes…

I went to very similar issue with a 2018 Q6 and SmartThings hub v2.
I experienced many of what is being discussed in here.
I had a ticket opened with Samsung and it was over 30 days of back and forth without getting anywhere. Tech support couldn’t find anything.

Some of the issues I experienced:

  • SmartThings app can control TV functions, turn it off but the app CANNOT turn it on.
  • TV showed in the google home app as a Switch and not a TV.
  • The switch (representing the TV) in the google home app didn’t turn the TV on or off.

Here is how I got it fixed and what I learned from it:

  1. First I told Samsung to close the ticket (let’s leave it like this :wink:)
  2. Then I removed all Z-wave and zigbee devices from my SmartThings hub (just because if make it easier to re-add them if they are properly removed).
  3. Then I factory reset my hub and my TV.
  4. I installed the latest firmware on the TV.
  5. I deleted the SmartThings app.
  6. And this is the fun part: I DELETED MY SAMSUNG ACCOUNT. No kidding, something was corrupted under my account. They couldn’t figure it out and ketp blaming my phone, TV, home network so… I figured: if I delete the account and and create a new one then I will no longer have to deal with corrupted data.
  7. Then I created a new account Samsung account.
  8. I re-installed the app and added the hub as if it was brand new (at this point I didn’t have the welcome code that comes with the hub so I had to call Samsung and email them a picture of the hub’s serial number and they gave me a new code).
  9. I made sure the TV was connected via WIFI (this is very important).
  10. I added the TV to the app.
  11. I linked the app to Google assistant.

And it all works as expected*.
And… what exactly was expected:

  • TV shows up in the Google home app as a TV (instead of a switch).
  • Google assistant can turn the TV on and off at any time and perform basic functions such as volume control.
  • What about SmartThings app turning the TV on? Well that doesn’t work but funny enough, according to Samsung this is by design. At this point the SmartThings app can turn the TV off but not on. So if the behavior is by design… it is not broken and if it is not broken… there is nothing to fix.
  • What about LAN? Another fun fact: as per Samsung’s documentation, you can only turn it on and off remotely if it is connected via WiFi, not a wired connection so your tv must be connected via wifi for it to work properly.

So far I’m enjoying the Google Assistant experience.

This is not true, did the steps. Still not working same problem, cant turn ON TV with smarttings or with the Google home. Problem is Samsung

Same here! so frustrating consider I’m trying to get these work 2019 TVS from Samsung? I could def see and understand issues with older TVs ?

One thing to note that may be a lead: there is an app called Simple Control (a.k.a Roomie remote) that does seem to turn off (and on ) the TV with wake on LAN. Not sure how they are successful doing it but may be an idea to use esp since I’m not sure Samsung will ever fix this

@Jeff_Lawson @Youssef_Bel_Mekki Sorry to hear it didn’t work for you.
@Jeff_Lawson Because it didn’t work for you doesn’t mean it is not true :slight_smile:

In the TV menu, under “Network/Expert Settings” there is an option called “Turn On With Mobile” (or something very similar to it).
Do you have this option check (set to yes)? This is also required in order for it to work.

Also just as an update to my previous post, I was told by Samsung that SmartThings app was supposed to turn it off but not on. I also read it on their docs somewhere.
They must have changed something because now I can use the app to turn it on and off.

Good luck to you guys.

1 Like

Yes I checked that and it’s checked correctly.

I actually think it’s a broader issue because I have two 2019 TVs, and two hubs (I don’t use both daily ) and neither work. So unless I’m just really unlucky and have two bad hubs and two bad TVs it would be incredible odds for this to be working correctly but not for me. Just saying

oh man. you are experiencing the same with both hubs and tvs you are right, there is more to it.
But if you deleted your Samsung account and created a new one you removed the possibility of corrupted data on their end. If the TVs are connected via wifi and properly set as you said… you have everything good on your end as well.

The only thing I can think of is something on your network blocking it?
I would go back to Samsung and keep “bothering” support until they get it right.

There is a same discussion on the webCoRE forum. Here was my look at the same problem. Wish you luck.

Mine is working fine with the following setup.
Check on the power on with mobile
From: settings - network - expert settings
The network should be on wireless, but i had the lan cable plugged in also, i let it there but when the TV is going off the lead from the router it will go off also but if I’m trying to wake up the TV with Google home is working every time. i don’t know If the lan cable helps or not but I told you when the TV is going off off the LEDs from the router is going off also and when the TV is on on the leds from the router comes back on but the connection to the internet is via wireless try that also but at my TV is working every time good luck

1 Like

Hello all,

Hope this helps as this is what I have done in order to get it working correctly

On tv

Settings > general > network settings > expert settings > power on with mobile (turn on) and enable IP remote .

Currently running wireless to tv

1 Like