Samsung Smartthings Chameleon energy

I am trying to set up smartthings energy and everytime I try to add my smart meter I keep getting this error message. I have had a smart meter for nearly 1 year now and it works perfectly, sending my gas and electricity information to my provider so not sure why Samsung smartthings can’t register it. Any help on setting this up would be much appreciated.

Have you opened a support ticket with both ST and Chameleon Technology support to see what they say? That would be my recommendation if you haven’t already :slight_smile:

1 Like

Thanks for the reply. I’m new to all this, how do I open a support ticket?

for ST support:

you can do it through the app in Menu > Contact us

or by the following:

US: 1-866-813-2404
UK support 0333 0000333

not sure about Chameleon Energy

Thanks for your help. It’s much appreciated

At what point does the error appear in the installation process?

Has it checked your meter is OK by this stage? It has to be enrolled in the DCC, i.e. be one of the meters that stays smart when you change supplier as Citizens Advice put it on their checker. Mine is so I don’t know what happens if it isn’t.

The error message comes up when you first set up, before you upload an energy bill. My home smart meter works perfectly as it sends regular gas and electricity information to my energy provider. I just can’t get the smartthings app to recognise my home smart meter now as I keep getting this error message. It all worked perfectly back in March but since then I can’t get past this error message.

The point is that there are two ways the information can get there. The original version 1 meters sent it directly to your supplier, but updated version 1 meters and version 2 meters send it to the DCC. Smart Energy needs the latter approach.

That does rather suggest the above isn’t the problem and your later screenshot confirms it.

I think the issue is the same as this thread

I had issues connecting at first with my SMETS1 ‘Secure Liberty 100’ meter which was using Secure’s own network instead of the DCC network. I only managed to find this out by asking my energy suppliers to check and confirm this. Unfortunately with my energy supplier being BULB the confirmation was the last email sent just as they were going onto administration. I don’t know if it’s set up properly now, as I did manage to connect to chameleon after confirming but less than useful in any way other than confirming I’m using energy and a bill over £0. Fortunately on old IHD3 v0.10.0 which never would connect with smartthings does still give me a relatively close estimate usage with the 10 second realtime delay.

I have the same issue. Set it up a month ago, but still haven’t received any data. I opened tickets with both Chameleon and ST, I’ll update this if I find out something

1 Like

Any one had luck with getting data to smartthings?

I have an IHD6 and was successfully able to add it. But my usage always shows 0. I tried deleting and adding again, but after months it’s still the same.

I am with octopus energy. Is the days only available for certain service providers?

It took me a while as linking to Chameleon doesn’t (or at least didn’t) work if your Location is on a US shard as mine was. Having moved it to the UK/EU it worked fine and once setup the data started flowing in to SmartThings Energy after a couple of days. It did stop some time in July but I uninstalled it and set it up again and it has worked fine ever since. Pretty pointless, mind you, as I can get the same info from my energy supplier.

The only slight incongruity is that the ‘Smart Meter’ device that gets installed just shows Energy Consumption that never updates from 0. I assume SmartThings Energy uses a private API in the same way SmartThings Find seems to. I feel there must have been a better way of presenting the device that didn’t make it look broken.

1 Like

A pointless sudo device as Graham describes

Thanks for the reply. I have no issues adding the device. Its just that the value is always 0 like your screenshot.

Just noticed that I can see the energy utilisation under Life > Energy in the smartthings app. This only shows the historic info until previous day. Doesn’t report in real time.

1 Like

An old post but I had been thinking it wasn’t working but it is actually logging historical data. Thanks.

It will also show smart plug energy useage if the smart plug reports power BUT i have only seen one member of the community reporting it working and he … i think, was in Germany. I have ST plugs and other plugs that report energy but non of mine ever show in the energy app, basically the app is a token effort but no where near useful

I have just spotted that a new device named ‘Gas Meter’ was created yesterday afternoon. In Samsung Energy it is suggested that the existing ‘Smart Meter’ device measures my total energy usage, and the new ‘Gas Meter’ measures my gas usage.