Samsung & Leviton Decora Switch problem

I have a 2 gang box, I install 1 DZ6HD-1BZ Dimmer, and 1 DZ15S-1BZ Switch. Paired dimmer first to SS Connect Pro, works perfectly though the App on my phone. I paired the switch next it paired OK, but appearred in the list of “All Devices” as “Z-WAVE RELAY” without the on/off icon. I researched and tried everything, wiring is correct, unpaired it, deleted it , excluded it, paired it again, deleted it and paired it many times. Dimmer right next to it works prefectly still. I went and bought another switch thinking first one is defective, paired new one, same thing shows up as Z-Wave Relay with out the on/off icon. Same problem as first one. I only have the 2 devices. Can anyone suggest a solution?

I had the same issue but corrected the device through the web API.
If you navigate here: https://graph.api.smartthings.com/location/list sign in and select your hub.
Next navigate to “My Devices” and find your switch. Click EDIT and then change the device “type” to Z-Wave switch.
This should give you the on/off icon.

1 Like

Thanks Mark, I gave it a try, still no on/off icon. I tried “Z-Wave Switch, Z-wave Switch Generic, Z-Wave Switch Secure”. In the API it knows the current state, if I turn it on and off manually it lists the state. I changed “Type” back to Z-Wave switch, It has been about 20 minutes now, in case I didn’t wait long enough first time.

Mark,
Your solution worked, just took a while I guess. Woke up this morning, on/off icon was there.
Thanks !

It can take a bit to sync. I have also noticed if you completely exit the app and then go back in, it’s a little quicker.
Glad it worked!

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.