Samsung hub on IDE advice please

Im having issues where I get the message “You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub”
I have been through all the previous posts, and tried many things, including resetting my hub and removing location, on the smart things app.
During set up I put my location in, and in the “Manage my home” on the app it shows my correct address under Geolocation.
However on the IDE when I click “home” this shows in the web address bar https://graph-na04-useast2.api.smartthings.com/location/show/68343aeb-d742-4177-ab23-e939d125b3ca
Is this right?
I appreciate there are posts with my issue in them, but I cant seem to get sorted no matter what I have tried
I have no access to my devices on the IDE page, as I am not showing a hub?
Any advice would be gratefully received
Thank you

Try starting here: https://account.smartthings.com/login

Use the same account as you use for your mobile app.

1 Like

Thank you
The link takes me to my IDE page (The same one that I am having trouble with)

Click on My Locations in IDE… how many locations are shown?

1 Like

Exact model of your hub? And if you are outside of the US, do you have the Vodafone model? If not, what country are you in?

1 Like

Thank you
I have 1 location (Home)
I am in the UK by the way

What is the model number of the hub? And did you buy it new or used?

1 Like

Thanks its a new hub V3 2018 IM6001-V3P non vodaphone

What comes after the P in the model number?

It should be:

IM6001-V3P02

not P01 Or P15

Sorry yes its a IM6001-V3P02

Ok, that’s a UK model, so that should be fine. When you go to add it, which exact option are you choosing. Can you show us a screenshot? (I’m only asking because the hubs which are also Wi-Fi routers are in a different device class group, and sometimes people get confused by that)

1 Like

I choose the Smart things hub 2018 (IM6001-V3P) option?
I will look into how to post screenshots
Thank you so far

Is your Samsung account a UK one? You are logging into the US IDE.

This is what my a
URL looks like:

https://graph-eu01-euwest1.api.smartthings.com/

2 Likes

It sounds like the IDE is connecting you to the wrong shard for some reason, or at least not the one where your hub is. I’m in the UK, but on the graph.api.smartthings.com shard. If I look on the EU shard that many UK users have been assigned, I see my location but no hub.

I think you probably need SmartThings support to look at your account.

3 Likes

Thanks for the help, I have emailed Support for additional help.
As I have no devices etc attached any more, I have removed the hub from smart thing, and reset it again
One question please, as I now have no hub attached to the ST app should I still be showing a location on the IDE?
It shows “Home” and when I try to delete it, this message is shown

Oh No! Something Went Wrong!

Error
500: Internal Server Error
URI
/location/list
Reference Id
71a62990-1a80-4a89-a0ed-66fddda4bf74
Date
Wed Jan 01 11:06:10 UTC 2020

This rings a bell. I had two locations at one time. I tried deleting one and got that message. The problem is they are both set to default. Changing the pesky location so it is not the default sounds easier than it is.

Samsung support emailed me and told me to open the new app, not the classic. In there i was able to delete the unwanted location. Wish I could remember but that should get you close.

1 Like

Try #2 in the following thread in the first post

1 Like

Are you certain you are signing into the correct account? Do you see the hub listed in the mobile app? If so, are you signing into that account in the IDE?

As a UK user, your location should be located somewhere such as https://graph-eu01-euwest1.api.smartthings.com/location/show/<locationId>

As mentioned, if you only have one location listed in the IDE, that is likely a “default” location which can only be deleted from the new app.

1 Like

Tried again to remedy this, thanks for the input, whatever I do I seem to be directed to that USEAST shard?
Tom, I deleted “my home” from the ST app, which meant I had to reset the hub again, and when I did, it asks me for my location which goes into the app as “My home” however that doesn’t show on the IDE page
All that shows on the IDE is “Home” which is the USEAST again
I have successfully made new locations on the IDE page and also successfully deleted them following JKPs advice.
I’m wondering why the location I set in the ST hub set up fails to show on the IDE.
The hub is listed and working, and I can add devices to it Brad, its deff the right log in, it was working perfectly, for months before this issue.

I would encourage you to double check this. If you look in the app, does the email address match the one you are using to sign into the IDE?

1 Like