Hub not showing up on


I’m new to SmartThings.

My hub is working and online. I can get to it with my mobile app and make changes. If I go to and log in with the same credentials that my app is logged in as, and click on, “My Hubs”, it says, “You don’t have any hubs yet. Please use The SmartThings mobile app to claim your hub”.

I thought I already did that during initial setup, or I wouldn’t even have a log on for the site.

Anyway, do you know how I can get my hub to show up here.

Hi Rick, where are you located. There are several SmartThings server clusters.

I’m in the UK and the url is:

For the US I think there are two:


1 Like

@slagle @Aaron @alex
Yet another one.
PLEASE, PLEASE, PLEASE sort this out for your customers.
Don’t you think this has gone on long enough.


Have you tried clicking on “My Locations” and then selecting your location? For me, this triggers another login prompt and then everything is visible.

1 Like

Yes, I can see it now!

1 Like

Just save that URL for the future and you won’t have to do that extra step each time.


So guys. Are you actually going to respond to this?

I am also getting wait times when loaded Smart Apps and device handlers well into 20-30 sec. if it loads at all. most of the time it’s 500 errors

Just an FYI on what I have noticed. I work on three separate SmartThing hubs located in different locations here in town. All three of the hubs have drastically different loading times. I just setup my stopwatch and the newest hub with only a couple of new device types, and custom smartapps, I can get My Device Handlers and My SmartApps to load in the blink of an eye. On the other end of the spectrum, I have a hub with 37 custom device handlers, 33 custom smartapps and 15 GitHub “Update From Repo” connections. And on this hub I just timed it and My Device Handlers takes 35 seconds to load and a whopping 85 seconds loading time for My SmartApps! It is frustrating but it seems to be tied to how much stuff I have loaded. FYI: I unloaded CoRE for this test

I believe that whether or not you have GitHub Integration enabled also has an impact.


Good point, I will update and say the fast hub does not have GitHub enabled and the slow hub has 15 “Update From Repo” GitHub connects.

1 Like

Damn I have 20+ maybe.

I’m having the exact problem as the original post. I can’t see my hub. I’ve tried the location thing and it didn’t help. What can I do? This seems overly complicated. I’ve also seen multiple posts on this with no response/help. Please help!!!

Please use this URL to log into SmartThings via the WEB IDE. This will automatically connect you with the correct “Shard” that your hub is hosted on.


That is the link I have been using. I just tried again. It still does not see my hub. Any other suggestions on things to try?

Are you in the USA or elsewhere?

Try the older manual method

1 Like

I’m in the USA. Not sure what the manual method is? This is the link I’m going to when logging in: When I log in there – no hub. I go to my location and see something like the below:
Name Events Notifications Devices Installed SmartApps
Wes Silotti events notifications devices smartapps

But, my device is not showing up nor is my hub. I can see both just fine on the Smartthings app on my phone. (I’m logging in to from my laptop but get the same results of no devices when logging onto the above link with my phone.)

Do NOT use to log into the ST IDE. That is only for users who happen to have their account running on that Shard. The thread I posted included all of the NA shards individual links (i.e. the manual method of figuring out which server your account is really on.)

The new way of logging in, via, should automatically take you to the correct shard.

If you recently created your SmartThings account, you probably have a “Samsung Account” and should select that option (if presented) as such.

Samsung/SmartThings has recently started to have all new users create a “Samsung Account” to use SmartThings, whereas old users still have “SmartThings Accounts” from back before Samsung bought SmartThings. This may be causing some confusion as well.


Dan, your my hero! I selected “Samsung Account” rather than Smartthings Account and it worked. I did have to select location and the “hub” and it was there. I’m trying to figure this all out and I’m sure I’ll have more questions to follow but your assistance in getting me over this hurdle is appreciated!