Samsung Account Issues (May 2024)

hi all. it seems account changes have happened recently with samsung/smarthings. has anyone had issues? today the app will not log me in, which needs to be authenticated with a samsung account. However if you try to log into the smartthings app from your phone, you routed to the samsung login page and you just get a white screen. if you try to log into your samsung account via the samsung webpage, you get so far, password all ok etc, but then are unable to accept the new terms and conditions…the button to do this seems to not work. Tried different browsers etc etc

try changing the default browser on your mobile device… then attempt to login with the app. You can always switch it back if successful.

can you list the URL used? was it or other?
does work? or You can also test them on a laptop or desktop to see if login works which could indicate something with your mobile device.

try using the QR code to login on the websites

hi jkp…
both my dot smarthings dot com and account dot smartthinigs dot com redirect to This is how it works on my laptop using a normal browser.

when you are in the app on a mobile it does this:
when you press the ‘sign in’ button on the smarthings app, you get routed to account dot smarthings dot com to log in.
IE the app loads a browser window on your phone.

IE the app routes you to the samsung login page, but after the user/pass is entered you just get a white screen outside of the app…
And samsung support is totally useless…all support links on all smarthings domain point back to samsung support…totally useless

try the following on your mobile device:

  • set the default browser to another browser. I saw you mentioned trying different browers but try changing the default browser on your mobile device to see if the ST app is able to login with the new default browser.
  • clear the app cache if using android.
  • uninstall/reinstall the ST app
  • if using a password manager… instead of letting it enter the data… copy and paste into the fields
  • clear browser cache
  • disable any ad/malware blockers

Desktop option to test if you can login to your account:

  • try signing in on a desktop browser to check if you are able to login.
  • You can also select to use the QR code option to sign in on the desktop browser.

those are some things to try

ive tried all that. thanks

I did a test today. If you create a NEW account, with a totally different email, you get the screen ive enclosed to agree to terms at the start odf the sign-up.

4 buttons and ‘agree’ button. Then you put your email in etc and the account is active. So then when you log in later, no problem…

However in my case my samsung account exists already.

So when i try to log in, i put the user/pass , then get the 2FA, all good, but then at the END i get this screen with the blue ‘agree’ button and the page does nothing when you press it…you dont finish the login cycle. Ive tried different PC’s, diferent browser etc etc. its just madness!!

The real issue here is that i can not log into my smarthings app and control any devices in my home, lights, switches etc as the smarthings app does not finish the login cylce. it just sits there with a white screen.

and there is NO ONE to CALL! samsung !! Now smarttihnfgs is part of samsung, good luck if you have the same problem. Right now, all of my devices, switches, sensors etc are totally useles to me. its a joke ans samsung need to sort this out…

The only way is a (for UK 08009951079) which goes to romania. yesterday when i called it was egypt! They try but are not that great…this has been going on for days… i seriously cant be the only existing account user this is affecting

Is samsung serious about smartthings, or is it being dumped.???.. this is really frustrating the way these business buy out companies, then shat all over them…and the users.,…


Samsung broke something, again.

(I get the same error at