Samsng A12 Won't Download

I Tried To Download The App On My Phone But It Said This Phone Is Not Compatible With This App And The App Works With Samsung 6 Phones And Up So How Do I Fix That

If you are trying to load it from Google Play, try loading from the Galaxy Shop instead.

Tried that already

Just had the same problem with my A12 … it downloaded OK from the Galaxy Store

It said this for me and when I looked on the galaxy store it wouldn’t show up

In the Galaxy store, click search for “smartthings” and it will appear

Yep didn’t see it

Isn’t smartthings in your region?

I guess I’m in usa

In Spain it cannot be installed on the A12 from the Google play store, but from the galaxy store it can.
It is the same versión 1.7.67.29, that Google play store

Still not working

What version of android are you using?

How do I check that

Settings/About Phone/Software Information. What is the Android version?

Are you sure you are looking in the Galaxy Store/Shop? The screenshots you posted are Google Play, not the Galaxy store. They are 2 different places.

It is a 10

Yes I am as I sent