Same LIFX Bulbs showing up twice

Good afternoon everyone,

does anyone know why each LIFX bulb shows up twice in the device list, once as itself and once as a placeholder? its showing up twice in smarthings and in google… is there any way to get rid of the placeholder? i tried deleting it with no luck in the Smartthings app.

thank you in advance,

Listed as itself means it was probably added through the old integration in the classic app. The placeholder means it was added through the new lifx integration in the new app.

1 Like

thank you jkp…

for now although it is sloppy i followed what is listed in this thread, and changed their names, and tucked them away in a separate hidden room. A little annoying…

Sorry, I should have responded on this part. You may want to keep the ones through the new app since. 1) the classic app will eventually be phased out; 2) the old integration in the classic app should have ceased working a few weeks back. If you wanted to remove them, you would need to do it in the new app > menu > settings > connected services

I will try to delete it this way. Thank you very much.

I tried deleting them from the home screen and they keep coming back.

You need to remove the LIFX Connect SmartApp in the Classic app to remove the old integration, the non-placeholder ones.

As part of the LIFX migration, the LIFX (Connect) SmartApp is already removed.

I meant uninstalling the SmartApp. I have seen already that it cannot be installed anymore.

Thank you Gabor.


Thank you gentlemen for your feedback.

You might want edit your previous posts and remove your phone numbers.

Thank you for looking out, I did remove it. It was the signature in the email. Have a nice day.


1 Like

I have this problem too.
I have been away for a a couple of weeks and when I return home recently and found all the LIFX bulbs not working.
The duplicates keep coming up.
I removed the smartapp in the Classic Smartthings IOS app but the names keep returning.
And it doesn’t actually control the bulbs.
Any ideas?

In IDE, the light shows up as a “placeholder” under “Type” and “LIFX|:lifx_plus_a19|:undefined” as the Device Network ID.

Placeholder is from integrations in the new app. You may want to open the new app, go to menu (three bars in the upper left of the screen) click on settings (the cogwheel) and select Connected Services. Open Lifx and go through the setup again and see if that resolves your lifx issues

Hello, thanks for your reply @jkp but which app are you referring to?
The LIFX app or the Smartthings app.
I just upgraded the LIFX app and now I have also lost one of my LIFX light strips. Painful!!

There are two SmartThings apps. There is the older version that is called SmartThings Classic and the new version called SmartThings. The classic version is in the process of being phased out. My guess is that you installed the lights in the Classic app. The lifx integration in that app ceased a few weeks back. So best advice is to use the integration from the new app at this point.

I am on Classic. But I move to the new app, I need to set up all the zigbee and z-wave devices again right?
I haven’t had time to revisit this forum recently but this was what I recalled from before which is why I never upgraded. If it ain’t broken don’t fix it. Unfortunately it seems the Classic app is starting to break…

All your devices will be available in the new app. If you are using presence sensor, Smart Home Monitor or Routines then you will need to set those up again in the new app. Advice —> delete the presence sensor and remove any SHM rules and then SHM and clear out your routines when you make the switch.

Thanks! Appreciate the info! Wish me luck!