Lifx Connect


I had my Lifx bulbs connected to Smart Things without issue. I then added an additional bulb to my system and it never would show up within SmartThings. I read that I should try revoking permission from cloud.lifx and then re-add it to SmartThings.

After I revoked permission, I now can’t re-add it in SmartThings. I still have the Lifx option showing but with 0 devices. When I hit “Remove” I get “An Unexpected Error Occured”.

I have tried restarting the hub, clearing the cache from the app on my phone. Not sure what else to try. Any ideas?

Thank you!

I don’t know exactly. I have 2x Lifx and these are my notes:

Restarted the hub without batteries?

Reboot the phone.

Delete the device via IDE. Delete the smartapp in IDE, if applicable. Then add from phone.

Maybe the bulb is already failed - does it respond in the Lifx app? I usually have 2 for color signalling, and it’s looking like they don’t live longer than a year. Mine often get their power cut, perhaps that shortens the life.

Maybe “An Unexpected…” is from a temporary cloud issue, and the only thing to do is wait a day or two, and try again. A fine example of a … inadequate error message.

I got an email in the last hour saying “Users are currently experiencing errors when trying to add and remove devices via the mobile app and the IDE. We have identified the issue and are working towards a resolution.” Might be related.

Good luck. Post a followup if it gets done.

Did you completely removed the Smart App and try again? Might be worth a shot, I know there’s a random intermittent problem between the ST <–> LIFX cloud which it’s not sure where the problem exists yet.

Hello all, thank you for the replies!

@ero4444 - Have restarted hub (not without batteries though). Have rebooted phone. Have no tried deleting device via IDE because I am trying to add a new device. I did not see a way to remove the Lifx Connect app via IDE, but maybe I overlooked that.

Bulb is working fine via Lifx app. Tried again today and still the same error. Totally agree re: the error message being totally useless!

@Benji - I can’t seem to remove the app, I just get an error when I choose to remove.

Using the 3rd party device handler is working fine though. I just have to manually add the bulb and then my API key so an extra step but probably one I would be taking anyways to use the device handler.

Thanks again!

1 Like

Yep in the same boat - I removed the Lifx app and can not now SYNC or add to ST. I have open a ticket Lifx. :cry:

@MIMOx3, Go to the new app, and add the devices through the new C2C integration. + Add Device and search for LIFX, log in with your LIFX account and follow the instructions on the screen.

@GSzabados no go just get circle of death proceed to next no prompts to connect accounts. :cry:

Ok, I see. This new C2C and regional thing is causing a big mess.

Can you click on that supported devices button?

Otherwise, now LIFX owns the integration and obviously there are teething problems. Try to contact them, but it definitely will take days or maybe weeks.

Yes but gives the user no useful help; ATM I have none of my lifx light are in ST. I even tried ST classic however lifx lights are now missing from device list. Even using lifx app and using Integrations Smartthings is useless.

Cheers @GSzabados

You can try to contact ST support, but the Australian one really doesn’t exist.

@tech2urdoor, any advice?

It sounds like i’ve been lucky. I have many lifx devices working perfectly fine with smartthings since I got it. I always used the new app for everything as I when I came aboard they were just beginning to phase out the classic. It does seem like this regional thing is creating an issue but you can’t rule out issues with lifx either since they are upgrading their app which could have messed with their cloud integrations. I’m sorry I don’t really have any advice other than checking that the permissions are actually revoked in the lifx cloud and trying to add them again in smartthings at a later date…

It’s only been a problem recently since updating ST new app. A couple stop working in ST so I tried to remove and re-add & the rest is history. I have 40 Konnected zone’s and working sweet. I hope Lifx can get it storted soon.

Cheer @tech2urdoor @GSzabados