Running SmartThings in Chrome Browser

Now that Google Chrome can now run Android apps locally, I thought I’d give it a shot in running SmartThings on my Windows 7 desktop. After following the linked guides, I can report that I can successfully control SmartThings from my Windows 7 machine.


Are you running it on a touch interface or mouse? How is the responsiveness of the apps running in Chrome?


I’m running a mouse interface.

It’s pretty darn responsive. I’d same the same as the Android app.

I have an iphone so i cant generate using the chome apk packager. So does anyone have a link I could use to download smartthings app to load into chrome?

I made one. Seems to work well on my Chromebook

1 Like

thank you. worked perfectly

@NickW I follow the directions and downloaded and install but cannot get smartthings to work on windows 8.1? If it work on windows 7 should on 8.1? was there any other step beside what was listed on the post? all I get is an open box with the smartthing logo in center? Any suggestion?

@llcanada, I have ARChon Custom Runtime installed as well, but I am not sure if is necessary. Also, are you using your own packaged APK or @korban_hadley 's one? You might need to login into the Android app before packaging the APK. I am not sure, though.

I dont think APKs work that way. It does not work on my windows 8.1 machine as well if that helps. I did not have time to play with it to see why.

I also try and put it on a windows 7 computer and still no luck. Thanks for the reply @NickW. I will try and figure out what when wrong. Thanks.

Just a quick test for me. So far in Chrome on Windows 7 x64, I get “This app is not compatible with this Android device version” message when launching. And on MacBook Air I just get the SmartThings logo. Might try again when I get some free time but not really sure I want to use this anyway.

On OS X I get just the ST icon popping up in a phone sized window as well. Using both the posted and my own APK from my tablet. I’m compiling on a linux box to make the apk from a download from the play store now. If it works I’ll post back.

Update…compile failed.

@acastal, @Dlee, @llcanada

Try looking at this issue ticket and see if you can get it to work.

Thanks, I downloaded a newer version in that thread and it works with the apk I made. This is on OS X.

Interesting that it sees the old picture icons I made (in things) that I afterwards removed.

Edit: It is snappy and responsive, having this option is very nice.

1 Like

I’ve got to say Awesome…

Running an acer chromebook, connected to my 27inch monitor… and can now run smartthings from my pc…

Thank you google, and thank you smartthings…


would you mind adding the link you used and your apk? os x here and keep getting an icon. thanks!

I’ve spun off a topic: For a more complicated variation: Android Emulator “”

1 Like is

ARChon Custom Runtime 1.1.1 - x86_32 38.4410.120.25

I think that’s what made the difference. I made my ST APK by following the third link in the OP. You need an android phone/tablet to do this I think.

awesome, thank you… working now!

I think this is a great idea but it won’t load for me. The window launches in portrait mode and the ST logo is in the center, but it remains stuck there. I have tried it on Windows 7 and 8.1 and current versions of ARChon runtime 1.2 as well as 1.1 and current version of ST 1.6.6. Any ideas?