SmartThings Community

Routines not triggering and/or are partially executing

#70

I built a simple “Lights on at Sunset” routine and it blatantly didn’t even fire tonight. Nothing in the logs…

A less techy friend of mine just purchased a house and is looking for some simple, but reliable automation (lights on at sunset) and I’m having a hard time recommending SmartThings

(Chain) #71

Just purchased ST at Christmas… I set up a simple routine called “Dusk” to turn on the back door light 30 min after sunset. It worked for the first 4 days. Then today nada… It’s about as simple of a routine as you can get… I guess ST isn’t ready for prime time. Was really hoping this would work and am disappointed. How can Samsung sell a product that’s not even close to ready?

Normally the notification says:
Performing “Dusk” for you at sunset as requested
I turned on the light back door entry and dimmed the lights to 100%.

Then tonight it only says:
Performing “Dusk” for you at sunset as requested

It never turned on the light… When I manually ran the routine it worked fine… Any ideas?

(Bruce) #72

There tend to be peaks of event traffic at popular times that can cause problems with Routines, or anything, running at that moment. Best practice for now is to offset the time by a few or several minutes from things like sunset, 9:00 pm, etc.

(Chain) #73

It runs 30 after sunset… And I assume sunset is different times for most… Anyway, thanks for the reply. Can you explain peak times? I amused the routines were saved locally on the hub so I don’t understand peak times since I’m the only one using my hub. After all if the routines were run from the cloud how would they execute with no internet or power? After all that’s why the hub has battery backup right?

Thanks,

Chain

(Bruce) #74

You are correct. If your routines run locally, then what I wrote is irrelevant. There cannot be peak time for local processing.

#75

Local processing at the present time is extremely limited, basically just a few lighting automations. At present, routines do not run locally.

See:

1 Like
(Seth Staggs) #76

I have my Good Morning routine setup to run at 5:40 am every weekday and all it does is turn on some lights, turn on the TV, and disarm the Smart Home Monitor. It randomly doesn’t run which is frustrating, because it’s a secondary wake up alarm for me.

(Greg) #77

I’m starting to see this behavior as well.

Goodbye will run, but not do (or even say it did) the things that it is supposed to do (turn off lights, turn on SHM, etc)

Other times it will run and there are no problems.

Quite frustrating.

(Ernie) #78

Do the routines work if you trigger manually? I have Rule Machine backing up non-time triggered routines and Tasker/Sharptools backing up time based routines. Backups have not failed to date.

1 Like
(Greg) #79

They do work manually, but with the same inconsistencies. Sometimes yes, sometimes no.

I’ve been meaning to set up a RM back up. Guess I was hoping I wouldn’t have to.

(James) #80

I’m also experiencing these issues. It’s my first dive into home automation and quite frankly I’m unimpressed with the reliability of ST.

I have my “Goodbye!” and “I’m Back!” routines set to activate when my presence sensor leaves / returns but they never seem to run?! I can see in the activity feed that the status of the presence sensor is being detected correctly.

We shouldn’t have to create “backups” in Rule Machine!

#81

I have a very simple setup with routines that are supposed to trigger simply based on time of day and nothing else. No custom device types, all fully supported/certified devices included in the routines and I’ve had nothing but inconsistent issues and have had multiple tickets in with support, one of which is still open and has been for months now. I’m going to give rule machine a shot today and see if I can ditch all of my smart lighting and routines to convert everything over. I’m really hoping this works. If not, my last resort is to use my Logitech Harmony hub to program routines so the timing of these events actually works and is reliable but I haven’t started down that path yet.

#82

Routines which were working properly suddenly are not…which, from what I read in this thread, is not something that’s exactly new. What is interesting is that the SmartThings app is reporting that it has successfully completed actions…which it hasn’t–turned off lights, locked door. When you check out the actual Things dashboard, the lights are still on, door still unlocked…not sure how to deal with this. Any suggestions?

(Steve S) #83

FWIW, status.smartthings.com is reporting issues with routines right now. So they’re working it.

Edit: Just got the notice it’s cleared up…

#84

They should just leave that notice up. :persevere:

#85

Not sure it’s really fixed. I just set up smart things for the first time this week, but this morning my presence sensor (mobile phone) properly sensed me leaving the geofence area, and executed the Goodbye routine which then switched to away mode and reported turning off my lights. However a quick check on the things tab showed the lights were in fact still on so I manually had to turn them off remotely.

Is this the exact symptoms everyone is reporting? Sorry, but really only a 3 day Smart Things user.

#86

Your experiences are exactly what most of us are experiencing regularly (unfortunately). The outage mentioned in the last couple of posts was related to a mass-outage that they actually reported that they addressed, not the continuous issues we have been experiencing; which is what you describe here. I think during that outage period there was some sort of bigger system outage that affected routines that they reported. The intermittent issues you describe are the same as the rest of us and seems to at least partially go back to the cloud infrastructure in one way or another not being able to handle the amount of I/O since most of the system is cloud based and not locally executed commands.

#87

I would think a volume issue would just result in a large slowdown. This seems more like a code bug or authorization issue where one of the final steps in the process link between local triggers (leaving geofence area) and cloud execution (sending off command to specific devices) is failing to actually execute even though the notification has properly occurred. Sorry to see this is not reliable at all right now, but the powerful integration has so much potential if they can isolate the issue and fix.

#88

Somewhere on this board recently (I looked for reference and cannot find it) was an infrastructure engineer (that does not work for ST) that described over his years of experiences the same type of command “loss” through large systems. I too can speak on this to some degree with my experience in IT infrastructure. One would think that commands in a queue would eventually just keep piling up, keep processing, and eventually or hopefully catch-up, creating a large lag or delay in commands. That’s not actually what happens as the queue is flushed after a certain amount of time (that’s based on the system’s programming). So what you find are some events that are delayed and then some that just never happen. Likely what is going on with the ones that never happen is they hit the queue, they are not processed in time, and the queue is flushed before they are executed. So on your end, it looks like something just didn’t work or didn’t happen when really the command was never processed through their cloud and sent back to your local hub for execution. That’s why you are starting to hear people advise to move your routines off of the :00, :15, :30, :45 times. Even support just advised me to move my routines off of the hard times and move them a few minutes in one or the other direction to see if this helps… that right there shows that they are trying to have you send the command (request) to the cloud at a time when the system is less busy.

#89

Thanks for the detailed reply. My stuff has been executing pretty well for the past few days. Hopefully they have improved something.