SmartThings Community

Rooting a Kindle Fire with OS 5.3.2?

smarttiles.click

#16

I’m not sure what happened on mine but I used the same tool and the Google Play Store doesnt work. I was able to roll back the OS to 5.1.2.1, block OTA and turn off the lock screen ads but the Google Play store always just says it can’t connect. I may need to delete it and try again. I’d also like to figure out how to delete or hide some of the built in bloatware.


(Mike) #17

rootjunky probably has some tips on his youtube channel. i had issues with playstore but that was on my 1st gen Fire, and i think that was just because the app wasnt compatible with that OS. You might also just reboot and try to install the play store again, from what ive read some of these things take a couple of tries.


(Benji) #18

Anyone know how stable the CM or AOSP ROM is these days?


#19

Thanks for all of your help. I went through the whole process of rooting, remove ads, block OTA updates, install nova launcher, install fully browser.

I do still have an issue with the lock screen, and this may be a setting I may have missed. I have the device turn off after 15 seconds of inactivity. If I provide motion shortly after, the screen turns back on without a lock screen. If I leave it alone inactive for a while, the amazon lock screen continuously appears every 15 seconds or so. And when I provide motion, it goes to the lock screen as well. Is your setup still consistently waking up without a lock screen?


#20

Does ST still automatically log you out after the tablet falls asleep idle? How are you guys getting around that? I stopped using it on my Nexus 7 because of that and haven’t even tried on my Black Friday-acquired Fire 7.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #21

I think there are a lot of suggestions in the main SmartTiles v5.8 Topic and the SmartTiles CSS & Mounting Topic.

But I won’t hesitate to assure you that ActionTiles (ST V6) doesn’t have this problem and our Beta testers love it.

I really wish I could give you a release date; we are certainly getting close, but the closer we get, the more and more little details show up that are necessarily to “polish” to ensure we have a smooth launch. Thanks for the support and patience.https://community.smartthings.com/t/smarttiles-dashboard-theming-custom-css-and-mounting-hardware-ideas/11222?u=tgauchat


#22

Thanks! That’s good to hear. Looking forward to seeing AT but honestly I don’t think I’ll want to pay a monthly fee. For me a touchscreen dashboard is more of a nice-to-have/cool factor thing but I don’t have a strong use case for it. I’d probably just stick with voice control through Alexa and Google Home. I am considering using HomeAssistant as a dashboard for ST via MQTT. I’ve used HA before and it’s a pretty nice interface. But like I said, it was more of a cool factor for home automation. Regardless, I’m interested in seeing what you have coming with AT!


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #23

Thanks… We’re looking forward to showing it off, and especially making sure it is obvious that it will have the potential to have boundless continuous improvement and new features.

We want Customers to feel the price is reasonable and and incredible value. And the product / price is one they will recommend to all their SmartThings friends!

Stay tuned!


(Mike) #24

honestly im not 100% sure. i set both fires to turn the screen off after 15 seconds, but i think i have a setting in the Fully Kiosk app that keeps the screen on overriding the system setting. every time i walk into the rooms with the fires, the screen seems to be on before i get there, so i need to check that tonight.

i will say, though, the nexus 7 that i have ST on with Fully will turn the screen off, then it comes back up when i walk into that room. i did have to log it back in a couple of times, but i changed one of the settings in that app so every 10 minutes, no matter what, it will automatically refresh the page. Im hoping thats enough to make sure it stays logged in, since the app wont save my email/password, its a pain to retype it every night. i should know for sure tomorrow if it works, it would time out during the day while we are out of that room all day.


(Smuts) #25

To get rid of the lock screen you must get rid of FireOS. Just install Cyanogenmod. It’s pretty easy.

Root junky’s scrips are very simple. Open them in a text editor to see what they are doing. It will help when something goes wrong and the script can’t help you.

I have tasker wake the tablet every 15 minutes. All is well unless chrome crashes, which is does every couple of days, or there is an app update, which sometimes screws up tasker.

The stability of this setup leaves something to be desires. Too many things can go wrong. The Fire’s get slower and slower the longer they are on. There’s a memory leak somewhere. I see the same issues running FireOS 5.3.1 as CM 12.1. I think it’s Chrome. . . . . Right now there seems to be some kind of Smartiles issue. They all errored out and the launcher screen only has the help button. . . .


#26

Thank you, that was my next step.


#27

I went ahead with installing CM12 on it, removed lock screen, installed fully kiosk, enabled motion detection (when tablet goes to sleep) and auto reload every 15 minutes (for smarttiles login issue) and I seem to be good to go for now. Thanks for the help. Now I have to see if all of this will work on a Fire HD 8 as well.


(Mike) #28

I think I’ll do that, too. I guess bypassing the lock screen on the fire just won’t work. Sounds like CM takes care of that, so it’should worth a shot.


#29

Are you still seeing that the fire with fully Kiosk Browser turns it on with the lock screen off? I rooted and turned off the OTA like you then installed FKB and I keep getting an error that it can’t make itself the default home app. Thus when I approach it the lock screen is greeting me. I tried installing Nova like you did but it didn’t change the result. Is there a setting in Nova t allow this to work?


(Mike) #30

yeah, when mine wake up it goes to the lock screen. you might need to set Nova as the default launcher, but that probably wont fix the lock screen problem.

i think its an issue with the Fire OS. i hadnt realized that even though the OS was set to turn the screen off after 15 seconds, Fully was set to keep it on all the time. So when i turned that option off, when the motion would wake the screen, it would be the lock screen, Fully couldnt bypass it. It looks like thats a limitation of the OS, so im going to try CM soon (hopefully this weekend, at least on one of them) and see if that gets around it. Others in this thread have had luck with that, with all of the other configurations the same, so i really think its just something in fire OS that Fully cant get around.


(Mike) #31

Did you copy all the zip files to an SD card on the fire? I don’t have one so I’m worried I’ll mess something up when it tries to write info to the internal storage, where all the files are


(Mike) #32

Nevermind. FlashFire for the win!


#33

No I didn’t use an SD card


#34

Like Mike mentioned, I couldn’t get it to work as well by just rooting the fire. Had to go one step further and install CM 12. A lot more customization that way.


(Mike) #35

I put CM12 on one of them and it’s already working better. It turns the screen off and Fully will actually wake up the screen now how it’s supposed to. It wasn’t that tough with FlashFire, either, I just grabbed the wrong Google Apps package so that took a little time to work out. I’ll probably do the other one this weekend.