Rooting a Kindle Fire with OS 5.3.2?

smarttiles.click

(Mike) #1

Like many people here, i bought a couple of Kindle Fire tablets to use with my automation system over the last year or so, One had Fire OS 5.3.1 and was really easy to root with the right resources. Now with Chrome and a new launcher, it actually feels like a real tablet and is awesome for SmartTiles and my ST app. I have another fire that has Fire OS 5.3.2. O would love to root this one so i can do the same thing, but i havent been able to find any guides to root this OS. The root tool for 5.3.1 doesnt work. Has anyone done this? Or can i roll back to 5.3.1 so my current tool will work? Any input would be much appreciated!!


App for Amazon Fire Tablet?
(Don) #2

I did mine a while ago. I had to roll the firmware back to 5.3.1. Don’t remember what I used its all on my desktop at home. It can be done. I do remember I had to do it several times. I’m sure because I did something wrong. So one time I had to restore it and roll it back again then root it.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #3

Just for information…

I have a Kindle Fire for the purpose of testing ActionTiles. I’ve decided to keep it as close to “stock” as possible so that we know what customers of AT will experience.

So far, though, I have found that side-loading Chrome and/or Fully browsers is the best option. I have not required, nor tried, rooting, but that means no Play Store for automatic updates to those two apps.

Opera also seems to work ok, but not optimal.


#4

I purchased 2-fire 7’s and 1-fire hd 8 on black friday to use with smarttiles, harmony app, etc. I have no rooting experience but I was able to get the google play store on there to install Fully Kiosk Browser which allows for full screen, motion detection, etc. However, I can’t find a way to bypass the amazon lock screen or the ads (unless I pay to remove those). I’m assuming I would have to root it or install android on it to do that.


#5

I believe you are correct. There is the option to pay (I think $15?) to disable the ads on the lock screen, which might allow you to disable it all together (not sure). I think you could also root your device in order to remove the ads/lockscreen. But for me, I just decided to root and install CM to have a pure Android device. Didn’t really play with the Fire in its stock mode, so I can’t speak to that, but CM 12 on the Fire 7 is pretty smooth. I installed Fully Kiosk Browser and enabled the motion detection. Now it just sits on my counter in a tablet stand with Smarttiles running.


#6

I went the easy way and just added google play to my fire, so I could install Fully Kiosk Browser.
But I would love to know if I pay to remove the ads, will Fully Kiosk be able to skip the lockscreen or do I still need to root to be able to do that.


#7

I believe neither would do it. Someone mentioned in another post regarding tasker and motion detection that rooting doesn’t remove the lock screen. It looks like a full android install would have to be done.


(Benji) #8

What ROMs are you all using? I’ve seen CM mentioned a few times, anyone using anything else? AOSP?


(Mike) #9

Thanks for the suggestions! I installed Fully Kiosk browser to test it out (on the rooted one), but it seems a little buggy. Ill play more with it tonight, but it seems to have trouble waking the screen consistently. Id like to have one of my smarttiles pages running so it turns on the screen to that page when i walk into that room

I also found a guide to install google play store (and associated services) a couple of weeks ago, so ill dig that up so i can at least try Fully Kiosk on the 5.3.2 version. I suppose if i can get that to work i dont really need to root it.

Also, for what its worth, i also have a Gen 1 fire that i was working with and was able to root it really easily with KingRoot. Just search for it in the browser, download the APK and make sure you can install programs from unknown sources. Then run the app and in about 10 minutes you should have root access.

Ill update later today when i get some more time to either try and roll back to 5.3.1 or at least install the play store and the kiosk browser on the 5.3.2 version.


(Mike) #10

i was able to roll the 5.3.2 Fire back to 5.3.1, root it and get google play installed. im working on setting this one up with a kiosk browser and/or smarttiles, too.

Walkthrough on rolling back:

Firmware/OS
http://forum.xda-developers.com/showpost.php?p=62986665&postcount=3

im not entirely sure why, but when i rolled back i didnt lose any data. not complaining, just surprised.


(Benji) #11

First thing on that video it says don’t load an older firmware than the one your device currently has :smiley:


#12

the best info and automatic tools will be found on the XDA forums just search for your device


#13

Did this get rid of the lock screen? Or is it still on there when tablet turns on from motion detection?


(Mike) #14

haha, yeah i saw that but i rolled it back without any issues.


(Mike) #15

Check out this page. I used the tools in his “super tool” to block OTA updates (so it doesnt mess up the root), install Nova launcher and get rid of lock screen ads.

I finished that tablet about 930 last night, so i didnt have a ton of time to test it, but its mounted under a cabinet in my kitchen with Fully Kiosk that loads one of my smarttiles pages. I set the screen to turn off after like 15 seconds just for testing, and when i walked by it, the screen came on unlocked, to my smatttiles page. Same thing when i walked into the kitchen this morning to get my coffee before work. That tool looks like itll work on pretty much Fire OS thats on a 5th gen Kindle.


#16

I’m not sure what happened on mine but I used the same tool and the Google Play Store doesnt work. I was able to roll back the OS to 5.1.2.1, block OTA and turn off the lock screen ads but the Google Play store always just says it can’t connect. I may need to delete it and try again. I’d also like to figure out how to delete or hide some of the built in bloatware.


(Mike) #17

rootjunky probably has some tips on his youtube channel. i had issues with playstore but that was on my 1st gen Fire, and i think that was just because the app wasnt compatible with that OS. You might also just reboot and try to install the play store again, from what ive read some of these things take a couple of tries.


(Benji) #18

Anyone know how stable the CM or AOSP ROM is these days?


#19

Thanks for all of your help. I went through the whole process of rooting, remove ads, block OTA updates, install nova launcher, install fully browser.

I do still have an issue with the lock screen, and this may be a setting I may have missed. I have the device turn off after 15 seconds of inactivity. If I provide motion shortly after, the screen turns back on without a lock screen. If I leave it alone inactive for a while, the amazon lock screen continuously appears every 15 seconds or so. And when I provide motion, it goes to the lock screen as well. Is your setup still consistently waking up without a lock screen?


#20

Does ST still automatically log you out after the tablet falls asleep idle? How are you guys getting around that? I stopped using it on my Nexus 7 because of that and haven’t even tried on my Black Friday-acquired Fire 7.