Rooms missing devices - Android


(Jay) #1

Just noticed this last night. Going into most of my rooms, Im seeing lots of devices missing all of a sudden. Luckily everything is still in my things menu. I can’t even go back into those rooms and re-add because theres no devices to add. Going into the ide shows all my missing devices are indeed associated with the rooms still. I have restarted my phone and even reinstalled the app. I don’t recall seeing this issue in the community either. Its only effecting my api integrations - nest thermostat and protect, dsc (alarmserver) and ST integrated harmony hub (specifically the ST created virtual switches for activities). Support has a ticket since last night but no solutions yet. Any ideas?


SmartThings losing connection to TCP hub
TCP Lighting Integration Issue - 10/27
(Bobby) #2

It’s been like this for a few days now. If I were to speculate, they are getting ready for an update and been working on the back end to prepare things. Wouldn’t be the first time when that would happen…


Missing Device
(joe) #3

Yep, I have the exact same issue. I just noticed it last night though.


(I got a hair cut from Alexa) #4

Make sure those devices have a hub associated with them…even if they don’t really use your hub. :wink: I had that problem with my lifx bulbs disappeared from the room group they were in, though they still showed up in things. I edited the device in the web ST interface and chose my home hub from the pull down, and poof, they were back in their room group in the app.


(Jay) #5

Thx. Now I just have to do that 20 times haha.


(Robert) #6

Updating the Hub location in the IDE (it was blank) worked for me! Thanks.


(Kurtis) #7

I have seen the same thing on IOS. Fix above worked for me… editing each device and associating them with the hub… a pain.


#8

I’ve been doing that fix but unfortunately, some of my virtual switches that were created by an app to auto create a virtual switch including the Gentle Wake Up app keeps giving me
an error message when I try to edit it in the IDE:
“Access Denied
We’re sorry, but you are not authorized to perform the requested operation.”

I wonder if there is a work around? Fortunately I just have a few so I may simply recreate them or use some other logic in RM to bypass them.


(Matt) #9

Changing the hub from blank to my hub for them back! Great tip nx8d.

I’ve got the same access denied error for the MyQ garage door openers though. I submitted a help ticket. I’ll report back what I find out.


(Ryan Applegate) #10

This issue has been fixed and you’ll no longer have to do the workaround of adding a hub.


#11

Thank you, that may be true but I still have virtual devices (I think these are ones that were created from within an app SwitchMania or Virtual On/Off Switch Creator) that I can no longer access, delete, or move into a room. I will contact support and see if they can delete them for me.


(Jeremy Keen) #12

@rappleg I no longer have any rooms in “my home.” Is this a similar issue?


#13

i am having issues with rooms and i open ticket and no one responded. Now i just chat support and they told they will escalate this issue to developers,

i have those devices that are in those room, so i don’t need to re config them. but i was unable to add them to other rooms as it can’t find them as it already think its in rooms.

When i click those devices in IDE i am getting below error.

Access Denied
We’re sorry, but you are not authorized to perform the requested operation.

Hope they can fix it so that i no need to reset and config again which is lot of pain.

I also having lot of issue with SHM which i cant arm and disarm. they are working to fix it.


(Chris Etheridge) #14

I can confirm that all my rooms are missing as well. They were there yesterday. This is on both the iOS app and Android.