Ring Cameras Says Need Software Update on Family Hub Refrigerator But There is None!?

Rather than re-type this all and post all the photos here again, just go here to read and the lame response I was given (to come to THIS forum instead) all while they marked that as the “solved” (solution).

TL;DR: Today my Family Hub shows this error message that I need to update the Ring software app to view the cameras (which have worked fine for the past year or two). Except there is no app update when I click that little button and there’s no OS software update either!??!!

I called customer “support” (equally useless) and they had no clue and also said I was running the latest versions. They expect me to contact Ring (Amazon)… but it’s Samsung’s app that broke this; it was working fine for nearly a year. The 4 Ring cams work fine too in their Ring app, Alexa, Home Assistant, etc… “it’s not me, it’s you (Samsung)”

Anyone know what’s going on here?

1 Like

No clue, cleared the cache, still nothing. Haven’t contacted customer service yet. Same exact issue you are having.

You may not like my answer but I recommend contacting Amazon Ring support as they own and maintain the integration to SmartThings. They should be able to confirm if it is a problem on the ST side or simply refer you back to ST support. :man_shrugging: :man_shrugging:


So i factory reset and its closer…

The little live previews still don’t show up but if i touch a camera it shows the live stream. Better than before; still not great.

And because this forum is excessively restrictive I can only paste one image apparently in this post

…and now i have to wait 19 seconds to post another. Unreal.

If you performed a factory reset, did you lose all data, pics, etc?

INFURIATINGLY YES. It’s absolutely asinine that in the year 2024 there is no auto-backup nor a way to export your settings. I took photos with my camera of all pages and layouts. Also unbelievable is the photo management. These aren’t stored in your SmartThings (cloud or phone), so I meticulously went on my phone to find all the photos I had uploaded to Family Hub, then created a photo album and copied them into it. Now equally lame is you can only upload 10 photos at a time (and single video at a time). So I had to go through like 40 images that way. I had to re-login to Amazon and give access again, however it seems the “new” version of this setup is done by scanning a QR code which helped. I don’t recall doing that a year ago for setup. Then comes the downloading of every friggin plugin for SmartThings. So a lot of stuff doesn’t “work”, then you click the widget and it prompts to download, then it works after that. Some ST things did “save” (such as favorites and stuff, but those are global to all ST instances like on my phone/tablet/etc.). You have to tediously go through and set up all the preferences, backgrounds, screen order, widgets, blah blah… (hence the camera shots earlier)

This Family Hub has/had such potential but it seems a neglected service that is more gimicky than practical. I mean, it has some value… a glorified photo frame, calendar is helpful, Alexa is half-baked (for example, ask her to show you a video of how to do something… “Getting that from YouTube…” NOTHING shows :face_with_symbols_over_mouth:

And last, the food detection must be stored in ST cloud b/c that did seem to be populated. Although, let’s be honest, this is also a joke. It seems to recognize about 10 things and wildly off with everything else. Seems with Amazon’s gajillion images and AI and all that it could do better – oh right - it’s NOT leveraging that, it’s using Samsung’s pathetic database apparently. Basically useless without a LOT of customization. Furthermore, you’d THINK it would use the hive mind and as I add foods, it would upload them to some cloud so that we all benefit from our collective tagging. Nope; doesn’t seem to be the case.

But I digress…