Replacing a bad Z-Wave switch using Replace

I’m posting this because searching for it didn’t show a previous thread, and others might be in the same situation.

I had a bad GE in wall on/off switch. It was listed as offline in the app and did not function locally when pressing on the switch. I ordered a new one and emailed SmartThings about the easiest way to swap them out without having to re-add it to all the routines, automations, and scenes etc. They were useless. I tried back and forth and they kept answering the wrong question. Eventually they told me it couldn’t be done.

They were wrong, here is what I did, and it worked exactly as I hoped it would:

  1. Obtain new/unused device (not already included in the hub)
  2. Go to malfunctioning device and open Classic SmartThings app
  3. Go to device that is not responding
  4. Select gear icon to open settings
  5. Select Replace button
  6. Wait for app to attempt to fix problem. Takes a couple minutes. App then advises to continue. Leave app open on that screen.
  7. Turn off power to switch at breaker panel
  8. Remove old device
  9. Install new device
  10. Restore power
  11. Press switch on new device. (You do not need to include it or anything else first that will happen automatically.)
  12. Smarthings app screen changes indicating that the replace was successful. The app now lists the new device exactly as if it were the old device, without an error message, and listed as part of the old devices routines, automations, etc.

Hope this helps.

1 Like

A couple of comments I just thought of:

You MIGHT be able to just remove the old device and install the new device before opening the app and hitting REPLACE. It won’t find the old device because it physically isn’t there and wasn’t responding anyway so it should just tell you to continue and you can then hit the button on the new device. In theory, this should work. I don’t know I didn’t try it this way.

I used the Classic app, I don’t know if the same functionality is available in the new app. I don’t know if the same functionality is available from the IDE.

1 Like

“Replace” Is a standard Zwave utility, it’s not specific to SmartThings.

I don’t know why support didn’t tell you about it, they certainly should have. There’s an article in the official knowledgebase which is pretty straightforward:

Normally, when a new device joins the network, the Z wave controller (in this case, the smartthings hub) assigns it a new network ID.

The replace utility allows you to add a new device but give it the network ID of a previous device which has either stopped working or is no longer available. The two devices need to be highly similar in their capabilities, but it can save you a lot of set up if you have existing automations. :sunglasses:

And, yes, it’s fine to physically remove the old device and then install the new device before you start the replace utility. It’s all the same from the controller’s point of view. The hub will try to contact the old device. If it doesn’t respond, it will then begin the inclusion process for a new device but using the old ID.

1 Like

Has anyone tried this with the NEW SmartThings application? I started to look at a device that is “offline”. I am told the Device is disconnected, and not given any options to “replace” anything. It sounds like a an opportunity that hasn’t moved forward.

Has anyone tried this?
Todd

Just to confirm this: I had a Jasco ON/OFF toggle switch go bad this morning. I replaced it with a newer version (but still a Jasco Z-Wave ON/OFF switch), using the shorter method you mentioned above with the Classic app. It went perfectly with not only the switch quickly being replaced in SmartThings but all SmartApps (webCoRE, Alexa, GoogleMini, etc.) and other automations that were pointing to it also working just as they had before.

1 Like

I tried to replace a defective Leviton dimmer switch and had no luck using “Replace”. I physically removed the old switch and installed the new one, then using the Classic app I hit REPLACE…It ran for a while then timed out. Tried it twice and it timed out both times.

I did not have that many pistons associated with the switch, so I just went ahead and deleted the old switch from ST, added the new switch to ST and then updated the associated Smart Lighting app and pistons.

I’ve never been able to make the replace functionality work. Which sucks, remove switch, install new switch and re-add it back into all the smart apps, fix webcore pistons, etc…

I just tried the method above. With the screen showing “ready to replace” still open, and the new light switch installed, the app stayed stuck on that screen doing nothing. I waited a bit, then went back to try and re-run the replace method again. It timed out. But, when I went back to turn the switch on/off in the app, it worked. Not sure why smart things didnt say anything about it being complete or if I need to do anything else, but at least it’s working… Even with Alexa. The zwave portion must have been updated in the background… Hopefully.

It looks like that Help article has been taken down. I cannot get Replace to work in the classic app. Anyone else?

OK, I got it to work by ignoring the text and icons on the app.

  1. Replace the defective switch with a new one but DON’T add it to the hub.
  2. Hit Replace on the switch and ignore the spinny thing, watch the TEXT change to READY.
  3. Toggle the switch on and it will replace teh defective switch.
2 Likes