Removing smartapp

Since a couple of days my light scenes are going crazy. Lights go on and off whenever they want, scenes get stuck in on state etc. This after years of working flawless and without having made any recent changes at all.

It got to a point that the lights are acting up so much that ive decided i have to remove all lamps, scenes and the Hue b smart app from smartthings. I think the problem lays with the smartapp.

After that i guess i will give the regular hue+smartthings connection a chance. Control some motion lights with webcore and the usual scenes maybe with ifttt.

i just went to delete the hue b smart app… But as to be expected nothing is ever easy and works as it should…

I cant delete the hue b smart app or the device type handlers. So im stuck with lights going on and off and i cant delete the app and reinstall hue. What to do?? This is getting really frustrating. Spent 2 days trying to control the scenes differently and failed. Now i just spent my evening on reading this forum on how to delete this app and also failed.
I will contact support aswell, but who knows how long that takes and i need to address this problem quick.

This is how i tried to delete the app:

IDE / My SmartApps DELETE - Cannot delete this app because its being used by 1 or 2 users
IDE / My Locations / SmartApps / Edit / Uninstall - There was an error uninstalling your SmartApp.
in the APP on my phone (android) - SmartApps / APP / Remove / Are you Sure? / Remove - An unexpected error occurred. ( tried in both the new and the old app)

Do you need to remove all the associated devices first? Perhaps from the hue b smart smartapp? Then remove the smartapp and then the device handlers.

Well i hope not. Removing a scene takes several clicks, several times loading screen and theres this ‘are you sure?’ pop up.

Concidering i have way over 100 scenes, bulbs, groups etc it would take a serious amount of time to do so.

It is a possibility though. Because i have deleted 1 scene and 1 bulb just to check if im able to delete them.

You will not be able to remove the device handlers until theybare no longer associated with any devices. That means either removing the device (if it was installed aa a child from an smartapp) or removing the device itself. Same thing with everything up the chain. (can’t remove a smartapp until its no longer associated with any device)

Meaning id have to delete over 100 devices one by one? thats too much!
Also it wont work as there will be more problems. I deleted 2 succesfully, and when i delete the 3rd i get this: Could not roll back Hibernate transaction; nested exception is org.hibernate.TransactionException: JDBC rollback failed

I now only see the devices in the IDE. no groups, scenes, groups anymore in the app. When i click on the hub in the app it does show all though

This is also not working. I have deleted my lux bulbs which i have only 2 of. Then i went to delete the DTH for the lux bulbs and get the same : DeviceType still in use by devices

I’m having the same problem trying to remove Echo Speaks. Gives me the exact same errors when I follow the same steps you did trying to uninstall your SmartApp. I can’t delete any echo speaker because every time I try to delete it in the new app, it acts like it’s doing something, but nothing happens. I ask it to delete again, still nothing. If I ask it to move to a different room, it does.

When I look at the log, it says this: groovy.lang.MissingMethodException: No signature of method: script_dth_c34bcd8a7526abc0243175c550d2bedc28a51ac0824afd02d11684765bfe6f36.updateSetting() is applicable for argument types: (org.codehaus.groovy.runtime.GStringImpl, java.util.LinkedHashMap) values: [resetService, [type:bool, value:false]] @line 3924 (settingUpdate

Did you ever figure this out? I’m having the same issue with Echo Speaks. I’m trying to clean everything up to prepare for the Groovy death and this one is fighting me.