[REMOVED] Nest Manager 2.0

@tonesto7 has been an animal getting this ready. Want to thank you and @E_Sch for working on this with me. There are some cool changes in version 2.0.

3 Likes

I updated via github and I get the below error. I made sure everything is updated and published.

There is a new device handler (weather) make sure you grab that.

Same here - all DH and new automations SmartApp updates and published. I had to go through my devices and delete multiple “Install Test” devices for each DT. The IDE logging shows
Cannot get property 'full' on null object @ line 529
for each InstallTest device.

The actual data in the previously installed devices shows up fine and uses the new DTH - the only things that is not showing correctly is the device type version (looks like it is not pulling the latest JSON for that).

I did make sure. Could this be that child parent app bug?

Awesome work - looks great (as long as I don’t open the Manager app for now…).

You probably would want to change

font-family: 'Lucida Grande';

in the in-page HTML to

font-family: 'San Francisco', 'Roboto', 'Arial'; 

for a consistent UI - see

Good call out on the fonts. Will get that in tonight. Not sure on the test devices, will see what tonesto7 has to say.

Hmm…everytime I go into the app and click done, it creates like 15 test devices. I deleted all of them out but still get same error.

@tonesto7 @desertblade

The issue seems to be with the following code:

        def testDevs = getAllChildDevices()
        if(testDevs.size() == 4) {

If you upgrade from a previous version and had devices installed getAllChildDevices() will return more than 4. testDevs should probably be filtered based on the presence of :InstallTest in the name.

I am having the same issue. It is installing multiple apps which says “Installtest” right next to it.

Update your code. I pushed out a fix to bypass device handler

1 Like

the installtest’s are the test device handlers installing. They will be removed after the test is finished

1 Like

Hi Anthony, I hit “done” and it shows the same thing that mbhforum sees, that device handlers are missing. Should I remove it and reinstall the app? that would count against your “install” count, would it? They show as installed in the IDE

Recent update fixed the issue. Thanks a lot!

if you download the most recent code the issue should be resolved.

I did - Thanks! So, the other installTest devices are still there. I have gone through the app and it showed as it should now and hit “done”. Should I delete the installTest devices or will they go away on their own eventually?

open the app and press done… I will remove them.

You will remove them? Are you the Borg? But yes, just opened again and hit “done”.

Nice, got it installed now! What do you recommend for turning off thermostat based on inside and outside temperature? Within 5 degrees?

Also, I found a bug possibly. When you save your automation, it says now running, but when you click done again, you get the dreaded “failed to save page:namepage” In the IDE logs I see(I scrambled the numbers below)

1174f55c-16c323332- a99e-3f541b923b8d 6:41:10 PM EDT: error java.lang.NullPointerException: Cannot get property ‘value’ on null object @ line 1055

Installed and working well for me now. I had to completely uninstall everything and redo it for it to work properly.