Removal of Contact Book Feature

There are several layers of caching in play, but the eventual source of truth goes back to the Account object. If your Location is still returning true for contactBookEnabled then try updating the Location via Edit -> Update like I described for the Account and that should rehydrate that object and start returning false for contactBookEnabled (assuming your Account has also already been updated).

In terms of the input parameter in existing SmartApps, by default it’s likely that most of them are just going to stop sending notifications if they have not been updated and they are written according to the guidelines. When you go back in to update them though, they should display the push notification/SMS options instead of Contact Book options once your Location and Account caches have pulled that new value.



Just for clarification, at some point during the next day or so all the caches will be flushed and contactBookEnabled will start returning false without the user having to go into the SmartApp or doing the workaround steps, is that right?

It could potentially be up to a week depending on the last time those objects were cached, so throughout the next week everyone will start to see that change reflected at different times individually. As mentioned anyone can force the refresh by updating their Account objects and potentially also their Location objects. The migration steps mentioned at the beginning of this post in which Contacts are manually deleted can also still be performed by anyone, but once their contactBookEnabled flag refreshes the feature will be disabled regardless of whether Contact objects still exist on an Account.


Hey looks like it the cache refresh just kicked in all my (compliant) apps switched over to push notifications. Works great!


Guess my contacts will stay configured forever.

Is anyone else getting errors when trying to click the “delete” button next to the edit button when viewing your contact in IDE?

“Access to was denied
You don’t have authorization to view this page.

This was a temporary error.


Try incognito mode
It worked for me believe it or not

So I have to change the code on my Spruce Watering System Smartapp???

I didn’t get around to updating this before they removed it. More than one week’s notice would have helped.

Presumably this is something they’ve been working on for a while, so I’m not sure why we couldn’t have gotten more of a heads up.

I have a day job that has nothing to do with ST, so I work on my hub when I can.

I’m with @tobycth3 on this one, really reminds me of the “upgrade” that killed the dashboard feature, and then it took them >12 months to release a replacement.

Looking back on things, the development strategy at ST since I bought a V1 hub in 2015 has felt like they’re repeatedly giving me the middle finger as an “old” user as they stumble from one “upgrade” to another and try to bring in “new” users.

Like @ogiewon and @stephack , I’m glad I’ve almost entirely switched over to hubitat. They’re a startup, maybe they’ll fold, maybe they’ll take their platform in a direction that doesn’t end up working for me, or maybe Samsung will acquire them and ruin things over there too. But so far so good.

In contrast, I’m pretty sure ST isn’t going to work out for me. In another year or so, if hubitat’s not meeting my needs, I could see myself giving ST a try again. If all that new shiny stuff that they’re promising now ends up actually improving things here.

Maybe they’ll even have a new contact book feature by then, sometime in 2019.


What replacement???


The favorites menu provides some dashboard functionality.

It’s not even really a replacement for what they had before, but it marked a change from nothing (back) to something.

They never really did anything else with it, and clearly they’re not going to update it any further at this point. I haven’t checked out the new app yet, so I hope they’ve figured out a way to provide a real dashboard by now.

Not that I really care, I can (and do) use actiontiles, since it’s always been a better dashboard anyway, and running in a separate browser window has its advantages.

1 Like

Do you run Action Tiles on Hubitat, Mark? I’ve been wondering about that…

If you still have a copy of an older version of smarttiles, you can get that working with hubitat.

It would be great to take advantage of some of the advances that actiontiles implemented, but that doesn’t look like it’ll happen.

Hubitat’s native dashboard is still a bit rough around the edges.


It would be awesome to have ActionTiles on Hubitat :wink:
Yes, I know, I’m screaming into the wind…but maybe one day…somehow…someway.
ah…ah…@tgauchat …chew


:wind_face: :ear: The wind hears you. We’d love to accommodate; but we don’t have the resources and risk tolerance that they have.


Can hibitat join smartthings as a secondary zwave controller which would let you use both systems fir zwave devices including actiontiles?

Truthfully, I don’t know much about configuring secondary controller. You should jump on the Hubitat forum and I’m sure someone there can give you the details you need.

That being said, there are smartapps available that let you sync devices in both directions. I used them while transitioning and they worked great at that time. I was even able to use actiontiles to control my hubitat devices. I would have kept it but when hubitat released there own dashboard it made the need for actiontiles a bit less. Actiontiles is still superior but I didn’t want the extra network noise from the ST hub so I had retire it…and actiontiles: (

1 Like

Even if you could, I’d not recomend it. I’ve tried connecting several other hubs (not Hubitat though) to SmartThings as secondary ZWave controllers and the result has always been negative. Although you can typicalally pair them at ZWave level, they don’t play nicely together.

Make developers mad and they will do what they know best, come up with workarounds. Thanks @tonesto7

[RELEASE] Pushover Manager Platform Integration